Shortcut keys are inaccessible while IME string is in composition mode

RESOLVED INVALID

Status

()

Core
Internationalization
RESOLVED INVALID
17 years ago
10 years ago

People

(Reporter: Wesley George, Assigned: masayuki)

Tracking

({intl})

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
<repro environment>
build 02-13-04 + Win98-JA, build 02-13-04 + Linux Redhat 6.2-JA 

not repro on: build 02-13-04 + Mac 9.04-JA, NS 4.7-US + Win98-JA, IE5.5-JA +
Win98-JA 

<repro steps>
1. place cursor in an edit field in mail, browser or composer 
2. turn on IME, type something (but do not determine the string) 
3. try to access a hot key, i.e., press Alt+F to access the File menu, or an
accelerator key, i.e., press Ctrl+F to access the Find in this Page dialog. 

<result>
Shortcut keys are inaccessible while IME string is in composition mode.
 
<expected result>
Shortcut keys should be accessible while IME string is in composition mode.

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

17 years ago
I think this is dup of 55751.
(Reporter)

Comment 2

17 years ago
#55751 occurs when the IME is turned on, but no composition string has been
typed.  Shortcut keys invoke menus, but then you can't select items from a menu.
#68717 occurs when there's a composition string. Shortcut keys do not invoke menus.

Comment 3

17 years ago
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong

Updated

17 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

17 years ago
Keywords: intl

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Target Milestone: mozilla1.0 → Future

Updated

14 years ago
Assignee: yokoyama → masayuki
Status: ASSIGNED → NEW

Comment 4

11 years ago
Hasn't this been bug fixed? I have no problem invoking a menu (e.g. Alt-F) while the IME is in the composition mode. 
This is limitation of IME. And it should not be accessible to any shortcut keys during IME composing. Because all key events should be processed by IMEs. I marked this to INVA.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Target Milestone: Future → ---
You need to log in before you can comment on or make changes to this bug.