Support the search with Firefox data contract in Windows 8

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: bbondy, Assigned: bbondy)

Tracking

({feature})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: completed-elm [metro-mvp])

Attachments

(4 attachments)

In Metro applications in Windows 8, you can go to the right edge of the screen and press on the share charm (icon).  This will bring up a list of contract providers that allow you to search in. 

It would be good for us to provide a search in Firefox capability that can be accessed from other Metro applications.
Depends on: 686835
OS: Windows 8 → Windows 8 Metro
Working on this tonight/tomorrow
Assignee: nobody → netzen
Base code for the search callback being activated when you click on Fennec when doing a search with the Search Charm.  I don't perform a search yet, I have to figure that out with content processes still.
Attachment #610977 - Attachment description: Patch v1. → Base search callback code
Whiteboard: completed-elm
Duplicate of this bug: 801134
Keywords: feature
Whiteboard: completed-elm → completed-elm [metro-mvp]
elm -> m-c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.