Last Comment Bug 687320 - Try to open correct libGL.so on OpenBSD
: Try to open correct libGL.so on OpenBSD
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86 OpenBSD
: -- normal (vote)
: mozilla10
Assigned To: Landry Breuil (:gaston)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-18 02:05 PDT by Landry Breuil (:gaston)
Modified: 2011-12-17 11:14 PST (History)
2 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Open libGL.so on OpenBSD (2.15 KB, patch)
2011-09-18 02:06 PDT, Landry Breuil (:gaston)
no flags Details | Diff | Splinter Review
Open libGL.so on OpenBSD (2.06 KB, patch)
2011-09-20 01:44 PDT, Landry Breuil (:gaston)
jacob.benoit.1: review+
Details | Diff | Splinter Review
Counter-proposal: always go for libGL.so since libGL should never break compatibility (2.58 KB, patch)
2011-10-12 20:05 PDT, Benoit Jacob [:bjacob] (mostly away)
ted: review+
Details | Diff | Splinter Review

Description Landry Breuil (:gaston) 2011-09-18 02:05:18 PDT
Followup to bug #650772, similar to #667325 and loosely related to #681026, i'm trying to test webGL on fx 7/trunk on OpenBSD, this won't work atm as we only have mesa 7.8.2 (but the update to 7.10.3 is in the works), but at least that patch makes glxtest and GLXLibrary::EnsureInitialized() try to open an existing libGL lib. On OpenBSD, libGL.so.1 doesn't exist, and the so version changes over time (see #650772 for more details), using libGL.so will ensure the last libGL.so installed is opened.

With that change (applied against 7.0b5, but patch is against trunk), at least the symbols are correctly checked (we're lacking glXBindTexImageEXT and glXReleaseTexImageEXT but i suppose that's a different issue)
Comment 1 Landry Breuil (:gaston) 2011-09-18 02:06:26 PDT
Created attachment 560769 [details] [diff] [review]
Open libGL.so on OpenBSD
Comment 2 Landry Breuil (:gaston) 2011-09-20 01:44:26 PDT
Created attachment 561141 [details] [diff] [review]
Open libGL.so on OpenBSD

Better patch that applies against tip.
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-10-11 12:56:50 PDT
Comment on attachment 561141 [details] [diff] [review]
Open libGL.so on OpenBSD

Looks fine; sorry for the long review delay.
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-10-12 19:55:50 PDT
Wait! why don't we just open libGL.so everywhere? At least here on debian, it is a symlink to libGL.so.1.

If the reason is that we don't want to crash when a new ABI-incompatible libGL.so comes out, then the present OpenBSD patch is not acceptable for this reason; but I rather think that OpenGL will never break ABI (or even API) compatibility since it never has in 15 years of existence; and when OpenGL ES 2 broke compatibility, the library name was libGLESv2.so not libGLES.so.

So I'd rather just use libGL.so everywhere.
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2011-10-12 20:05:39 PDT
Created attachment 566731 [details] [diff] [review]
Counter-proposal: always go for libGL.so since libGL should never break compatibility

See above comment for rationale.

Not sure whom to ask for review. Ted knows stuff and commented on the other bug.
Comment 6 Ted Mielczarek [:ted.mielczarek] 2011-10-18 07:09:24 PDT
Comment on attachment 566731 [details] [diff] [review]
Counter-proposal: always go for libGL.so since libGL should never break compatibility

Review of attachment 566731 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not sure that I'm the right reviewer here, but I don't have a better suggestion, and this looks pretty reasonable.
Comment 7 Benoit Jacob [:bjacob] (mostly away) 2011-10-25 05:41:10 PDT
Comment on attachment 566731 [details] [diff] [review]
Counter-proposal: always go for libGL.so since libGL should never break compatibility

Unfortunately, on our very own fedora 12 test slaves, libGL.so does not exist.
Comment 8 Benoit Jacob [:bjacob] (mostly away) 2011-10-25 05:49:54 PDT
Pushed Landry's patch:
http://hg.mozilla.org/integration/mozilla-inbound/rev/df2b31a1e4c4
Comment 9 Ed Morley [:emorley] 2011-10-25 18:09:19 PDT
https://hg.mozilla.org/mozilla-central/rev/df2b31a1e4c4
Comment 10 Landry Breuil (:gaston) 2011-12-17 11:14:57 PST
Thanks! I'd have gone the libGL.so route too, but i'm not surprised some oses only carry the versionned lib/soname.

Note You need to log in before you can comment on or make changes to this bug.