Firefox eats up all mem when browsing large pictures ("swap of death")

RESOLVED DUPLICATE of bug 573583

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 573583
6 years ago
6 years ago

People

(Reporter: myLC, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Replay:
Open
http://www.google.com/search?tbm=isch&hl=en&cr=&safe=active&q=wallaby&orq=wallaby+filetype:jpg&tbs=isz:lt,islt:40mp,ic:color,ift:jpg&biw=1680&bih=970
for instance.

Click on the 1st eight images or so with the MIDDLE mouse-button (to open them in background)...

Firefox (Aurora as well) will eat up more than 1GB quickly. The more images you open, the more the system (and Firefox of course) will become unresponsive – running into a "swap of death". You can easily freeze a system with 4 or even 8 GB this way. Under Linux it looks like this:
firefox.bin/status:Uninterruptible/Memory:1.2 GiB/Waiting Channel:sync_page

Doing the same with your contestants yields:
Opera: using about 600 MB – reacting quickly
Chrome: using about 58 MB – reacting fine

Conclusion:
Pictures should be decompressed on the fly – when being active (in foreground). Most CPUs (GPUs?) ought to be fast enough for this job. Firefox should postpone loading more images if running out of memory.
This is bugging everyone dealing with large pictures (photographers, people in the printing business, etc.).

Again – while Firefox can easily bring down an 8 GB workstation this way, both Opera and Google Chrome could do the same on a Netbook (and much faster).

Comment 1

6 years ago
bug 660577 / bug 661304 / bug 573583 / ...

Note that Firefox 7 will be discarding images in background tabs quicker.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 573583
You need to log in before you can comment on or make changes to this bug.