Last Comment Bug 687392 - Use nearest filter for mobile plugin rendering
: Use nearest filter for mobile plugin rendering
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla9
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-18 19:20 PDT by Oleg Romashin (:romaxa)
Modified: 2011-09-20 04:22 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use nearest filter for video and plugins when compositing not cheap (2.53 KB, patch)
2011-09-18 19:22 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Review
Use nearest filter for plugins when compositing not cheap (1.31 KB, patch)
2011-09-18 20:07 PDT, Oleg Romashin (:romaxa)
roc: review+
Details | Diff | Review
Fixed comment, to PUSH (1.31 KB, patch)
2011-09-18 23:55 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Review

Description Oleg Romashin (:romaxa) 2011-09-18 19:20:08 PDT
I found that with some recent changes GOOD filtering was enabled by default for all ImageLAyers...
That is not good for video and plugins rendering.
Comment 1 Oleg Romashin (:romaxa) 2011-09-18 19:22:33 PDT
Created attachment 560835 [details] [diff] [review]
Use nearest filter for video and plugins when compositing not cheap

This is will speedup video rendering in software mode a lot
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-09-18 19:52:56 PDT
Hmm, in the steady state BasicPlanarYCbCrImage::SetData should be prescaling to the right size. Is that not happening?
Comment 3 Oleg Romashin (:romaxa) 2011-09-18 20:07:49 PDT
Created attachment 560839 [details] [diff] [review]
Use nearest filter for plugins when compositing not cheap

Oh, yep you right, pre-scaling does the right thing for video element.
Looks like I have to consider it in my Media Bridge implementation.
Here is plugins only patch
Comment 4 Robert Longson 2011-09-18 23:44:25 PDT
bilinear is not spelled correctly in the comment.
Comment 5 Oleg Romashin (:romaxa) 2011-09-18 23:55:52 PDT
Created attachment 560859 [details] [diff] [review]
Fixed comment, to PUSH
Comment 7 Ed Morley [:emorley] 2011-09-20 04:22:58 PDT
https://hg.mozilla.org/mozilla-central/rev/9ae43404500d

Note You need to log in before you can comment on or make changes to this bug.