Last Comment Bug 687458 - TimeStamp in FPSState uninitialized, leads to crash
: TimeStamp in FPSState uninitialized, leads to crash
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla9
Assigned To: Florian Hänel [:heeen]
:
Mentors:
: 688247 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 07:56 PDT by Florian Hänel [:heeen]
Modified: 2011-09-22 08:39 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
initialize last timestamp (575 bytes, text/plain)
2011-09-19 07:56 PDT, Florian Hänel [:heeen]
romaxa: review+
Details
fix timestamp (702 bytes, patch)
2011-09-19 08:53 PDT, Florian Hänel [:heeen]
romaxa: review+
Details | Diff | Review

Description Florian Hänel [:heeen] 2011-09-19 07:56:06 PDT
Created attachment 560907 [details]
initialize last timestamp

The "last" field in LayerManagerOGL::FPSState is uninitialized and leads to a crash when trying to substract the null from the current time.
Comment 1 Oleg Romashin (:romaxa) 2011-09-19 08:41:49 PDT
Comment on attachment 560907 [details]
initialize last timestamp

Looks good, but could you attach patch with bug name and author?
Comment 2 Florian Hänel [:heeen] 2011-09-19 08:53:44 PDT
Created attachment 560926 [details] [diff] [review]
fix timestamp
Comment 3 Ali Juma [:ajuma] 2011-09-21 13:43:34 PDT
*** Bug 688247 has been marked as a duplicate of this bug. ***
Comment 4 Benoit Girard (:BenWa) 2011-09-21 21:18:32 PDT
pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/70e0fdded87d
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2011-09-22 08:39:35 PDT
https://hg.mozilla.org/mozilla-central/rev/70e0fdded87d

Note You need to log in before you can comment on or make changes to this bug.