The browser crashes while changing font size in Preferences dialog

VERIFIED DUPLICATE of bug 68208

Status

VERIFIED DUPLICATE of bug 68208
18 years ago
13 years ago

People

(Reporter: pmac, Assigned: matt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nsbeta1)

(Reporter)

Description

18 years ago
Platform: Mac (2001-02-13-04-Mtrunk).

1. Launch Netscape 
2. Go to Edit/Preferences/Appearance/Fonts
3. Change "Variable Width-Font" from 16pt sizes to 18pt sizes.
Notice that the browser crashes. It crashes in both Modern and Classic
skins.
(Reporter)

Comment 1

18 years ago
Since this bug crashes in browser, I nominate nsbeta1. This needs to be fixed.
Whiteboard: nsbeta1
(Reporter)

Comment 2

18 years ago
Below here is the talkback report:

 Trigger Type:  Program Crash 

 Trigger Reason:  PowerPC unmapped memory exception 

 Call Stack:    (Signature = 0xc10000fc 776d00e3) 
     
   0xc10000fc 
                                                   
     
   StyleContextImpl::ShareStyleData() 
                                                  [nsStyleContext.cpp, line 4141]
     
   StyleContextImpl::RemapStyle() 
                                                  [nsStyleContext.cpp, line 3912]
     
   NS_NewStyleContext() 
                                                  [nsStyleContext.cpp, line 4627]
     
   StyleSetImpl::GetContext() 
                                                  [nsStyleSet.cpp, line 837]
     
   StyleSetImpl::ResolvePseudoStyleFor() 
                                                  [nsStyleSet.cpp, line 1011]
     
   nsPresContext::ResolvePseudoStyleContextFor() 
                                                  [nsPresContext.cpp, line 647]
     
   nsComboboxControlFrame::CreateFrameFor() 
                                                  [nsComboboxControlFrame.cpp, 
line 2228]
     
   nsCSSFrameConstructor::CreateAnonymousFrames() 
                                                  [nsCSSFrameConstructor.cpp, 
line 5144]
     
   nsCSSFrameConstructor::CreateAnonymousFrames() 
                                                  [nsCSSFrameConstructor.cpp, 
line 5101]
     
   nsCSSFrameConstructor::ConstructSelectFrame() 
                                                  [nsCSSFrameConstructor.cpp, 
line 4187]

Comment 3

18 years ago
I got bitten by this bug as well on 2001021304 trunk (Win2k). Setting
Platform/OS=ALL.
OS: Mac System 9.x → All
Hardware: Macintosh → All
Looks like a duplicate of bug 68208 (same dialog, same stack trace).

Comment 5

18 years ago
agreed; dupe of bug 68208

*** This bug has been marked as a duplicate of 68208 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

18 years ago
Verified dup.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

18 years ago
This bug still occurs on Mac (2001-04-25-09-Mtrunk) if you change the "Variable
width font" from 72 pt sizes. I can reproduce all the time.
Seems work ok on windows 98 and Linux (2001-04-25-09-Mtrunk).
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.