Bad rendering of circumflex

RESOLVED DUPLICATE of bug 644857

Status

()

RESOLVED DUPLICATE of bug 644857
7 years ago
7 years ago

People

(Reporter: loic.grobol, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 560990 [details]
Snapshot of the issue.

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110919 Firefox/9.0a1
Build ID: 20110919030912

Steps to reproduce:

 1. Go to http://fr.wikipedia.org/wiki/Classification_des_groupes_simples_finis#Une_classification_de_deuxi.C3.A8me_g.C3.A9n.C3.A9ration
 2. See the fifth word “extrême”





Actual results:

 The ê is badly rendered. The same issue occurs on â, so I assume this the case with the other letters.


Expected results:

It should be rendered normaaly.

Comment 1

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110918 Firefox/9.0a1
Works on winXP
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
(Reporter)

Comment 2

7 years ago
The issue seems to occur only with FreeSans, and by only I mean not with DejaVu Sans. Note that FreeSans works normally on others Qt and GTK apps.
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110918 Firefox/9.0a1

Works for me on Ubuntu 11.04
I set the font to Free Sans medium and 10 for each of the options under the Font category in Appearance.

The text from the page provided in Comment 0 was rendered correctly.

Have you attempted to start in safe mode or with a clean profile and see if the issue occurs?
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110918 Firefox/9.0a1

Actually I can reproduce the issue on Ubuntu 11.04. Thanks for reporting and sorry about the rush with the previous comment, Loïc.

STR:
1. Set Preferences/Content/Fonts and Colors-Advanced/Sans-serif to Free Sans.
2. Load the webpage provided in the URL.

The circumflex e and the letter next to it seem to overlap each other.


Last good nightly: 2011-03-24
First bad nightly: 2011-03-25

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=741701875aec&tochange=e11c2f95f781
Status: UNCONFIRMED → NEW
Ever confirmed: true
I believe this is caused by an error in the font. See bug 644857 comment 12.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644857
You need to log in before you can comment on or make changes to this bug.