Last Comment Bug 687858 - Avoid measuring telemetry for size decodes
: Avoid measuring telemetry for size decodes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-20 08:33 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2011-09-26 08:12 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid accumulating telemetry for size decodes (1.72 KB, patch)
2011-09-20 08:35 PDT, Jeff Muizelaar [:jrmuizel]
justin.lebar+bug: review+
Details | Diff | Review

Description Jeff Muizelaar [:jrmuizel] 2011-09-20 08:33:16 PDT
These just add a bunch of noise to the data because they break some of the assumptions we have.
Comment 1 Jeff Muizelaar [:jrmuizel] 2011-09-20 08:35:55 PDT
Created attachment 561200 [details] [diff] [review]
Avoid accumulating telemetry for size decodes
Comment 2 Justin Lebar (not reading bugmail) 2011-09-20 08:47:14 PDT
Comment on attachment 561200 [details] [diff] [review]
Avoid accumulating telemetry for size decodes

r=me, but can we clear the existing telemetry data before we land this, so the histogram isn't further muddled?
Comment 3 Justin Lebar (not reading bugmail) 2011-09-20 08:48:21 PDT
Taras, how would we go about invalidating the existing data for this histogram?
Comment 4 Jeff Muizelaar [:jrmuizel] 2011-09-20 09:00:55 PDT
(In reply to Justin Lebar [:jlebar] from comment #3)
> Taras, how would we go about invalidating the existing data for this
> histogram?

In this case, I don't think we need to invalidate the data because we're not doing size decodes yet because decode on draw is not on. Still, I'm interested in the answer.
Comment 5 Ed Morley [:emorley] 2011-09-22 17:41:28 PDT
https://hg.mozilla.org/mozilla-central/rev/518c3a56a5da
Comment 6 Brian R. Bondy [:bbondy] 2011-09-26 08:12:56 PDT
Would it be useful to measure it but measure it separately?

Note You need to log in before you can comment on or make changes to this bug.