Last Comment Bug 687864 - Add offline renderer awareness for Mac OGL
: Add offline renderer awareness for Mac OGL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal with 1 vote (vote)
: mozilla9
Assigned To: Benoit Girard (:BenWa)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 687868 714723
Blocks: 568327 604135 646043 721285
  Show dependency treegraph
 
Reported: 2011-09-20 08:47 PDT by Benoit Girard (:BenWa)
Modified: 2012-01-25 19:44 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Workaround for blocker 687868 - Don't check for Layers support (4.66 KB, patch)
2011-09-21 12:24 PDT, Benoit Girard (:BenWa)
no flags Details | Diff | Splinter Review
Part 1: Add offline renderer awareness for Mac OGL in browser (1.64 KB, patch)
2011-09-21 12:25 PDT, Benoit Girard (:BenWa)
jmuizelaar: review+
Details | Diff | Splinter Review
Part 2: Add offline renderer awareness for Mac OGL in plugins (1.51 KB, patch)
2011-09-21 12:26 PDT, Benoit Girard (:BenWa)
jmuizelaar: review+
Details | Diff | Splinter Review

Description Benoit Girard (:BenWa) 2011-09-20 08:47:08 PDT
http://developer.apple.com/library/mac/#technotes/tn2229/_index.html

In a nutshell we need to declare our renderers as offline renderer aware and handle renderer change notification.
Comment 1 Benoit Girard (:BenWa) 2011-09-21 12:24:26 PDT
Created attachment 561539 [details] [diff] [review]
Workaround for blocker 687868 - Don't check for Layers support
Comment 2 Benoit Girard (:BenWa) 2011-09-21 12:25:20 PDT
Created attachment 561540 [details] [diff] [review]
Part 1: Add offline renderer awareness for Mac OGL in browser
Comment 3 Benoit Girard (:BenWa) 2011-09-21 12:26:02 PDT
Created attachment 561541 [details] [diff] [review]
Part 2: Add offline renderer awareness for Mac OGL in plugins
Comment 4 Benoit Girard (:BenWa) 2011-09-21 12:28:36 PDT
I don't check for renderer change notification currently. Do we need to update feature status that may differ between the two gpus?
Comment 5 Benoit Girard (:BenWa) 2011-09-21 12:35:04 PDT
Push to try:
https://tbpl.mozilla.org/?tree=Try&rev=478de21a4a56
Comment 6 Jeff Muizelaar [:jrmuizel] 2011-09-23 12:18:31 PDT
Comment on attachment 561540 [details] [diff] [review]
Part 1: Add offline renderer awareness for Mac OGL in browser

The way we set double buffer is sort of scary...

I also just thought about the impact that a change in max texture size could have on us.
Comment 7 Jeff Muizelaar [:jrmuizel] 2011-09-23 12:38:40 PDT
Comment on attachment 561541 [details] [diff] [review]
Part 2: Add offline renderer awareness for Mac OGL in plugins

It might be worth adding a comment near where we create the PBuffer that worries about it and mentions this url:http://developer.apple.com/library/mac/#technotes/tn2229/_index.html#//apple_ref/doc/uid/DTS40008924-CH1-SECTION7
Comment 8 Benoit Girard (:BenWa) 2011-09-23 13:25:32 PDT
Bug 687868 is no longer required FOR RELEASE BUILDS because apple sniffs our bundle ID
Comment 9 Ed Morley [:emorley] 2011-09-24 07:20:15 PDT
The try run in comment 5 shows the same OS X64 debug M-oth orange twice in a row. Is it related? I've retriggered it again to see if it was just bad luck with a not yet filed random orange.
Comment 10 Benoit Girard (:BenWa) 2011-09-24 07:51:03 PDT
I don't think they are related. This change can only get properly tested with hardware with dual gpu so I don't expected we would see any regression on tinderbox.

In any case I'll hold on check-in flag until this is resolved.
Comment 12 Ty Williams 2011-09-26 13:16:38 PDT
I see this is marked fixed. What is the timeline for releasing this fix?
Comment 13 Benoit Girard (:BenWa) 2011-09-26 13:54:56 PDT
Target is mozilla9, that's 20-Dec-11.

Note You need to log in before you can comment on or make changes to this bug.