Last Comment Bug 687885 - Don't use resetUseCount() outside of ifdef JS_METHODJIT
: Don't use resetUseCount() outside of ifdef JS_METHODJIT
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: Sun OpenBSD
: -- normal (vote)
: mozilla9
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-20 09:38 PDT by Landry Breuil (:gaston)
Modified: 2011-09-22 18:20 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed fix (981 bytes, patch)
2011-09-20 09:40 PDT, Landry Breuil (:gaston)
bhackett1024: review+
Details | Diff | Review

Description Landry Breuil (:gaston) 2011-09-20 09:38:03 PDT
Followup to that commit : http://hg.mozilla.org/mozilla-central/rev/9ca3d16d575c

Build now fails on sparc64 (where JS_METHODJIT is undef) with :
js/src/jsinfer.cpp:6041: error: 'struct JSScript' has no member named 'resetUseCount'

See http://buildbot.rhaalovely.net/builders/mozilla-central-sparc64/builds/165/steps/build/logs/stdio

Imo the call should be included within JS_METHODJIT as the releaseScriptCode call upper.
Comment 1 Landry Breuil (:gaston) 2011-09-20 09:40:34 PDT
Created attachment 561218 [details] [diff] [review]
Proposed fix

Trying that patch here, results in http://buildbot.rhaalovely.net/builders/mozilla-central-sparc64/builds/166/steps/build/logs/stdio and apparently it fixes the build issue.
Comment 2 Brian Hackett (:bhackett) 2011-09-20 10:25:18 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/21a39c2f9060
Comment 3 Marco Bonardo [::mak] 2011-09-21 02:54:21 PDT
https://hg.mozilla.org/mozilla-central/rev/21a39c2f9060
Comment 4 Ed Morley [:emorley] 2011-09-22 18:19:58 PDT
Is possibly the cause of the macosx-debug_spidermonkey-shark builds going orange: (NB you need to use TBPL &usetinderbox=1 so the logs show up, due to bug 685299)

https://tbpl.mozilla.org/?tree=Mozilla-Inbound&usetinderbox=1&jobname=spidermonkey&rev=21a39c2f9060

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1316539496.1316543246.4464.gz

The last JS touching changing before this (https://tbpl.mozilla.org/?tree=Mozilla-Inbound&usetinderbox=1&jobname=spidermonkey&rev=5a3e49205389) was green.

Note You need to log in before you can comment on or make changes to this bug.