I'm unable to keyboard to "continue anyway" from the untrusted site page.

RESOLVED FIXED in Firefox 13

Status

()

Firefox
General
--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Janina Sajka, Assigned: dao)

Tracking

({access})

Trunk
Firefox 13
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110906120836



Actual results:

Unable to recall my password, I requested a reset from Hurricane Electric's tunnelbroker.net page. When I accessed the https address they provided via email I recieved Firefox's "untrusted site" page. I could only keyboard to the "get me out of here" button. I couldn't keyboard to a button that would allow me to continue to connect. Fortunately for me, I was able to use lynx to solve this problem, but I should have been able to use FF, as I have always done in the past. This seems new with FF6. I'm on Fedora 15 with AT-SPI2 and Orca, so must be able to keyboard. Mouse is impossible for me.

Updated

6 years ago
Component: General → Disability Access
QA Contact: general → disability.access

Comment 1

6 years ago
Janina, by 'to keyboard' you means tabbing, virtual buffer navigation or something else?

Comment 2

6 years ago
Yes, tabbing. Orca doesn't have a virtual buffer.

Comment 3

6 years ago
(In reply to Marco Zehe (:MarcoZ) from comment #2)
> Yes, tabbing. Orca doesn't have a virtual buffer.

then it's keyboard navigation bug I think
Component: Disability Access → Keyboard Navigation
QA Contact: disability.access → keyboard.navigation

Comment 4

6 years ago
Still an issue with latest nightly. Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → x86
Version: 6 Branch → Trunk

Updated

6 years ago
Keywords: access
(Reporter)

Comment 5

6 years ago
Hi, I need to confirm this is still a bug. I'm currently at IBM in Austin in a W3C Face to Face. It seems the SSL cert for the IBMVISITOR wifi service has expired, so triggers the "untrusted site" screen. I can only TAB to "GET ME OUT OF HERE." i ASKED ONE OF MY COMMITTEE COLLEAGUES TO MOUSE TO "cONTINUE ANYWAY," OR WHATEVER IT'S CALLED. tHEREAFTER, EVERYTHING WORKS ok. bUT, BY MYSELF, i'D HAVE BEEN FULLY BLOCKED AT THAT POINT.

Comment 6

6 years ago
Enn, Mats, a tabbing issue. Would you please take a look?
Nothing to do with either of us. The dialog has some poorly designed expander widgets that aren't accessible.

Comment 8

6 years ago
(In reply to Neil Deakin from comment #7)
> Nothing to do with either of us. The dialog has some poorly designed
> expander widgets that aren't accessible.

mm, ok, maybe Dao could help?
(Assignee)

Updated

6 years ago
Blocks: 431826
Component: Keyboard Navigation → General
QA Contact: keyboard.navigation → general
(Assignee)

Comment 9

6 years ago
Created attachment 603709 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #603709 - Flags: review?(mak77)
(Assignee)

Updated

6 years ago
Severity: normal → major
Hardware: x86 → All
Comment on attachment 603709 [details] [diff] [review]
patch

Review of attachment 603709 [details] [diff] [review]:
-----------------------------------------------------------------

thanks!
Attachment #603709 - Flags: review?(mak77) → review+
(Assignee)

Comment 11

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/501247d9125c
Target Milestone: --- → Firefox 13
https://hg.mozilla.org/mozilla-central/rev/501247d9125c
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Hi, looks like this revision regressed https://hg.mozilla.org/mozilla-central/rev/290d329672e5 . Only the h2 is removed now, instead of the whole expert content.

Sorry if I'm not supposed to comment a fixed bug.

Comment 14

6 years ago
(In reply to Hector Zhao [:hector_zhao] from comment #13)
> Hi, looks like this revision regressed
> https://hg.mozilla.org/mozilla-central/rev/290d329672e5 . Only the h2 is
> removed now, instead of the whole expert content.
> 
> Sorry if I'm not supposed to comment a fixed bug.

please file a new bug and make sure to cc Dao.
(Assignee)

Updated

6 years ago
Depends on: 742645
You need to log in before you can comment on or make changes to this bug.