Open .eml message with "X-Unsent: 1" header directly in edit mode (ala template)

RESOLVED DUPLICATE of bug 166541

Status

enhancement
RESOLVED DUPLICATE of bug 166541
8 years ago
2 years ago

People

(Reporter: peuktreuk, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

958 bytes, application/octet-stream
Details
(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110912 Firefox/9.0a1
Build ID: 20110912030829

Steps to reproduce:

I used to save standard messages to my desktop & outlook express would open them
with the ability to modify To/From/subject, when those messages aren't sent to me
or deleted, but in editing mode. I could reopen them & modify those fields, other
email clients treat those messages the same way besides thunderbird.


Actual results:

no ability to edit To/From/Subject/Body (even though those bodies are already
present in the eml files that act like templates, but are eml files.

I'm not interested in using templates & be condemned to work with templates
only because they're referenced & accessed through tb more easily than where
i place my eml files in my hd & where i can secure their folders, etc etc. & loading
templates on a secured folder would be tricky & may be buggy.

& Eml allows me a direct access by opening files from wherever i want .. .


Expected results:

You allow users to open eml files by default while ignoring their content. 
So, tb doesn't read a single header code in order to understand if 
the email has been sent/received, or is a "new message" & is in 
edition mode .. . then allowing the ability to open eml files while 
restricting the mode of those emails is limited ((

I have many eml files from oe that have no subject, no from or
to data, & those files are treated as new messages, like many other
e-mail clients do, not because to/from/subject is empty but a header
code shows it's in edition mode.

It would be wonderful to open email files that way.

When i drag & drop eml files to the view panel that have
been previously received or sent, they're positioned properly
though.

Comment 1

8 years ago
Can you attach a sample eml file to show what is the content of the files you mention. You can of course remove the private text in body, you can replace it with random characters.
(Reporter)

Comment 2

8 years ago
Posted file eml file
Yes but my aim isn't to tweak or adding a crutch to any eml files i would have created from msoe mso or wlm .. . but make tb detect headers of the eml file
& treat it as a new message without adding "to" or "subject" or selecting "from" fields when they're empty .. . & treat received messages just the way it does, greying out from/to/subject .. . dissociate states.

Comment 3

8 years ago
Ok, that file opens in Thunderbird (7) as a static message and can't be modified in any way.

You request the ability to edit the message (To, Subject, Body) and eventually send it?
(Reporter)

Comment 4

8 years ago
yep, that's my problem )) exactly ))
(Reporter)

Comment 5

8 years ago
yep, that's my problem )) exactly ))

& the body as well to partially change the body for personalisations at times,
just like a "new message" what tb would treat as a template but with eml files too.

Comment 6

8 years ago
Have you tried Message -> Edit as new, or Ctrl-E ?
(Reporter)

Comment 7

8 years ago
It's an option, but i'm requesting the feature to automatically detect the eml tag in order to open it directly "as new", instead of having to use a crutch & having to close the original message like a type of "bug" ((

Comment 8

8 years ago
Ok. Edit as new opens a new window whereas the original eml file stays open in the old window. The new window should replace the original. I confirm that request.

I am not sure on automatically opening in edit mode, probably other users do not wish it that way.
Status: UNCONFIRMED → NEW
Component: Message Compose Window → Composition
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: message-compose → composition
(Reporter)

Comment 9

8 years ago
"I am not sure on automatically opening in edit mode, probably other users do not wish it that way."

that's a regressive reply .. . what you wa&nt to propose is also regressive,
because it's a crutch .. . someone has to use another function to edit an opened
window .. .

many email clients treat eml files either on edition, or static,
because they read the eml header code before treating the content
properly & you seem not to want that .. .

it's very regressive why do you think people would want emails launched
from the desktop restricted to view ? it's a restriction, not a plus nor
evolutive, even exchange from win95 or oe from decades ago allowed the proper
treatment of eml files.

people open templates in edition mode, why not eml files too ?

because it's a microsoft file ? then why do you allow opening eml
files by default through tb ? it's a Pretention to be able to read
eml files when ou don't read them properly.

result:

Pure Vanity.

keep up with the restrictions, & i'll keep wondering why i'm begging for evolutive & standard email client's options at mozilla after decades of
development .. .

maybe i hould just forget about tb since u'll never want to update it
with benefice. but keep replying with regressive rejections.

Comment 10

8 years ago
But you can't just request the program to operate exactly your way and disregard the rest of the world. But I do not know the numbers of user preferences.

The bug is confirmed, the developers will decide.
This works for me:

1) Open .eml file
2) Right click in the message body
3) Click "Edit as New..."
Oh, I see that's been mentioned. Given that this is already possible, I think this is WONTFIX.

(For reference, I think the current way is good, since it's easy to go from displaying a message to editing it, but not vice-versa.)
Whiteboard: [wontfix?]

Comment 13

8 years ago
Yes, but don't forget the part about switching to edit mode creating a duplicate window with the message in edit mode, not closing the old one. I think at least that could be fixed.
(In reply to aceman from comment #13)
> Yes, but don't forget the part about switching to edit mode creating a
> duplicate window with the message in edit mode, not closing the old one. I
> think at least that could be fixed.

This part should really be rolled into bug 534907.
(Reporter)

Comment 15

8 years ago
Jim rocks, another regressive comment "this works for me" The crutch i mentioned when it could be more simplified, with instant access making tb detect "new message" states of eml files .. . & another regressive comment from aceman as well .. . "But you can't just request the program to operate exactly your way"

you're: rock & roll aceman .. .

if you ask me the way on the street, i'll make sure to give you the longest method just to make you waste your time & make you turn around, you probably have a judicious question to ask me aceman, "why" ? why ? because you can't just request information that would ease your approach & disregard the rest of the streets.

oh dear .. . the rest of the world, THE WORLD has been editing eml files from their desktop since decades & other email clients do. or do you have eccentric free animosity against microsoft ? that's the question ? Yes?!

Then do not pretend that tb can load eml files & make tb open them by default
when you restrict the detection of email states.

& of course it works for you, clicking on a menu function, crawl to the right toolbar meny & select a function as a "crutch" to get to your "Eml" template .. .
it should really be moved to that other thread, of course it works .. . like chosing 50 streets to get to the street you want to go, motive: it works!

GOOD GOD, GROW UP GUYS. be progressive or close the thread & i'll understand u simply don't give a **** to make tb evolutive after decades of updates. when many other free email clients treat eml files properly .. .

people actually cannot open files from the desktop as "new messages" as templates, unless they select it from tb's menus, maybe you could name
a news type of template that can be opened as a new message from tb, like
emv, to make sure it's not my way or u restrict old ms messages to be
treated by tb as well .. .

it's not "my way", it's old ways, compatibility, benefices & accessibility.

let me satisfy ur infantile negativism:

CLOSE THIS **** THREAD & DONT COMPLAIN THAT I TRY TO MAKE TB MORE VERSATILE
& ACCESSIBLE. but dont keep making vain comments & show regressive attitude,
cause i got my does, here's the fic: CLOSE THIS **** THREAD & GO PLAY WITH URSELVES.

GOOD LORD.

ur negativism is so bloody INFANTILE & AIMLESS & ur comments r so bloody immature Porter, grow up.
lola is requesting what I have changed the summary to (I think). As such, it is an enhancement request. I haven't checked for duplicates, so => unconfirmed. 

I don't see how this request can be accomplished, when the expectation (per standards) for an eml file is to open the file in a message window. But, what if the file has a different extension? Is there a standard extension that says "this is a template"?
Severity: normal → enhancement
Status: NEW → UNCONFIRMED
Ever confirmed: false
Summary: Open messages with To/From/Subject in edition mode → Open .eml message file with To/From/Subject directly in edit mode (ala template)
(Reporter)

Comment 17

8 years ago
"when the expectation (per standards) for an eml file is to open the file in a message window." 

No, repetition mode: there are two modes in eml files: "new message" (edition mode)
& static emails that have been received for example. if i have to find the tag that makes oe interpret it as a "new message", & delete step by step, i will do it since you're obssessed & confused with not knowing what code tells a client an eml is in template "mode" .. .

i agree with ur sandbox second vain comment is emk was a POPULAR email format & widely used ................................ .

ty.
(In reply to lola from comment #17)
> "when the expectation (per standards) for an eml file is to open the file in
> a message window." 
> 
> No, repetition mode: there are two modes in eml files: "new message"
> (edition mode)
> & static emails that have been received for example. if i have to find the
> tag that makes oe interpret it as a "new message", & delete step by step, i
> will do it since you're obssessed & confused with not knowing what code
> tells a client an eml is in template "mode" .. .

(I don't admit be being obsessed) additional information will be helpful for everyone, not just me.

better yet, would be references to any information (rfc, etc) about about .eml or any other format that implies a file is a template, that we perhaps should be supporting.


> i agree with ur sandbox second vain comment is emk was a POPULAR email
> format & widely used ................................ .

I don't find any references to emk format. When was such a format popular, and what clients supported it?

> ty.
yw
(Reporter)

Comment 19

8 years ago
it's irony, mr vanity. to bring u back to earth & reminding u that i'm discussing about the eml format & that if a follow u we could even create new extensions & make them recognized as templates if u want .. . eml is a popular format & in the meantime, my request addresses, yes, u got it, the eml extension & not the emk or emkvh ? (if possible) extension .. .

take care.
I have disabled lola's account. The sort of abuse in comment #15 is not acceptable in our community.

Gerv

Comment 21

8 years ago
yes we needed your consistency, that's very productive, thanks for the contribution Gervase. has anyone ever told you anything about brainwashing in 2011 ?

Sweetheart ? i'm 36, let me offer you a 4 word expression i'd offer to a 4 year old:

"rejection is a merit"

yes love, like consideration .. . & attention.

sleep well. i have better things to do now.

Comment 22

8 years ago
France.

Comment 23

8 years ago
To ease the process .. .

If the devs of thunderbird want to add more compatibility in the way eml is treated in thunderbird, the proper way, without having to wait for a 37th addon .. . here's the code that thunderbird should detect in order to treat eml files as what you guys call templates at mozilla (To/Subject/Body in edition mode):

X-Unsent: 1


Like that, all microsoft email templates saved as eml, created & unsent,
& saved locally for future use, will be treated properly by thunderbird
& not treated as a received read only message .. .
Summary: Open .eml message file with To/From/Subject directly in edit mode (ala template) → Open .eml message with "X-Unsent: 1" header directly in edit mode (ala template)

Comment 24

8 years ago
Is that header in all your eml files? Does outlook add that header automatically to all the exported files (unsent)?

Comment 25

8 years ago
outlook, or oe, or live mail, they all insert that tag in "new mail", when you compose or even reply in full edition mode, the head goes to all eml files & that's how all microsoft email clients detect eml files in edition/template mode & not "received & read only"

Comment 26

8 years ago
header* not head, is then saved if saved in edition mode.

Comment 27

8 years ago
Melin, i meant "aka", not "ala", that was a typo, but it's not important.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 166541

Comment 29

6 years ago
c'mon, "X-Unsent: 1" header exactly means that You want to open this email in edit mode. I'd love this integrated in Thunderbird.

Comment 30

6 years ago
Notice this is a duplicate of bug 166541 so please move there. I've already CCed you.
Whiteboard: [wontfix?]
Comment hidden (offtopic)
You need to log in before you can comment on or make changes to this bug.