[SeaMonkey] Windows Build Failure due to Bug 648581

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Callek, Assigned: Callek)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
Bug 648581 broke SeaMonkey by adding crashreporter annotations in a codepath we can't add them from.

Firefox gets around this by using a newer startup path, and Thunderbird fixed this breakage by morphing some/all of that new startup path into their code in one fell swoop.

I do plan to do that startup work in a week or two, but have not begun it yet, and rather than introduce potential further issues when trying to fix a bustage, I have a simpler [Temporary] solution.

My solution eliminates the ability for us (SeaMonkey Only) to add a CrashReporter annotation in the case of a failed DLL Blocklist load. (Which is entirely new with this m-c patch anyway, so is ok for SeaMonkey)

Asking kyle to review both these patches (c-c and m-c) since it is build-system in the end, and NPOTDB for firefox.
(Assignee)

Comment 1

7 years ago
Created attachment 561644 [details] [diff] [review]
c-c patch
Attachment #561644 - Flags: review?(khuey)
(Assignee)

Comment 2

7 years ago
Created attachment 561645 [details] [diff] [review]
m-c patch
Attachment #561645 - Flags: review?(khuey)
(Assignee)

Updated

7 years ago
Attachment #561645 - Attachment is patch: true
(Assignee)

Comment 3

7 years ago
http://hg.mozilla.org/mozilla-central/rev/1985330ca298
http://hg.mozilla.org/comm-central/rev/dfe1e3af4773
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 688411
You need to log in before you can comment on or make changes to this bug.