Last Comment Bug 688366 - [Skia] Fix Skia bug with radial gradients of the same radius
: [Skia] Fix Skia bug with radial gradients of the same radius
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Matt Woodrow (:mattwoodrow)
:
Mentors:
Depends on:
Blocks: 687187
  Show dependency treegraph
 
Reported: 2011-09-21 22:27 PDT by Matt Woodrow (:mattwoodrow)
Modified: 2011-10-31 11:20 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix radius check (1.01 KB, patch)
2011-09-21 22:27 PDT, Matt Woodrow (:mattwoodrow)
jmuizelaar: review+
Details | Diff | Review

Description Matt Woodrow (:mattwoodrow) 2011-09-21 22:27:24 PDT
Created attachment 561657 [details] [diff] [review]
Fix radius check

This appears to be an invalid check. Two circles with the same radius, but different center points shouldn't be rendering nothing.
Comment 1 Jeff Muizelaar [:jrmuizel] 2011-09-23 12:43:18 PDT
What's the test case that this affects?
Comment 2 Matt Woodrow (:mattwoodrow) 2011-09-26 23:46:46 PDT
I don't remember exactly, I'll disable this and run tests asap.

Looks like there is a skia bug open too: http://code.google.com/p/skia/issues/detail?id=311
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-10-03 11:45:54 PDT
Comment on attachment 561657 [details] [diff] [review]
Fix radius check

Good enough for now.
Comment 4 Matt Woodrow (:mattwoodrow) 2011-10-30 17:50:40 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e48babb549ce
Comment 5 Matt Brubeck (:mbrubeck) 2011-10-31 11:20:04 PDT
https://hg.mozilla.org/mozilla-central/rev/e48babb549ce

Note You need to log in before you can comment on or make changes to this bug.