Last Comment Bug 688468 - Fix up nsIFrameMessageManager::sendAsyncMessage/nsISyncMessageSender::sendSyncMessage IDL signature
: Fix up nsIFrameMessageManager::sendAsyncMessage/nsISyncMessageSender::sendSyn...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-22 07:50 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-08-03 16:17 PDT (History)
1 user (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (13.74 KB, patch)
2011-09-22 07:50 PDT, :Ms2ger (⌚ UTC+1/+2)
bzbarsky: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-09-22 07:50:34 PDT
Created attachment 561737 [details] [diff] [review]
Patch v1
Comment 1 Boris Zbarsky [:bz] (TPAC) 2011-09-23 21:11:35 PDT
Comment on attachment 561737 [details] [diff] [review]
Patch v1

You need to rev the iids.

>+ * the Mozilla FOundation.

s/O/o/

This patch is inconsistent about whether one casts between jschar* and PRUnichar* with static_cast or reinterpret_cast.  If the former works, stick with it!

>+          if (!JS_ParseJSON(ctx, reinterpret_cast<const jschar*>(nsString(aJSON).get()),

As long as you're here, PromiseFlatString(), please.

r=me with those nits.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2011-10-02 07:15:19 PDT
https://hg.mozilla.org/mozilla-central/rev/c7ee75aca277
Comment 3 neil@parkwaycc.co.uk 2012-08-03 16:17:36 PDT
(In reply to Boris Zbarsky from comment #1)
> (From update of attachment 561737 [details] [diff] [review])
> >+          if (!JS_ParseJSON(ctx, reinterpret_cast<const jschar*>(nsString(aJSON).get()),
> 
> As long as you're here, PromiseFlatString(), please.

Still wrong. aJSON.BeginReading() suffices, because we don't need the string to be terminated.

Note You need to log in before you can comment on or make changes to this bug.