Flash plugin not unloaded and using CPU when not needed

RESOLVED DUPLICATE of bug 501485

Status

()

RESOLVED DUPLICATE of bug 501485
7 years ago
7 years ago

People

(Reporter: notforyourmail, Unassigned)

Tracking

9 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0a1) Gecko/20110922 Firefox/9.0a1
Build ID: 20110922030907

Steps to reproduce:

I ran nightly.  At some point, I hit a flash site.  Days later, I was no longer browsing a site that uses flash, but the Shockwave Flash Plugin Process was still running, and was using approx 3% CPU on a core 2 duo laptop.  After restarting nightly, the process was not running.


Actual results:

The plugin process continued to run and use about 3% CPU even when I was not on a page that uses flash.


Expected results:

The plugin should be unloaded when not in use, saving CPU and RAM usage.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501485
You need to log in before you can comment on or make changes to this bug.