New throbber animation for Fennec

RESOLVED WONTFIX

Status

Firefox for Android Graveyard
General
RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

Trunk
Firefox 9
Dependency tree / graph

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 561964 [details] [diff] [review]
part 1: new throbber asset

+++ This bug was initially created as a clone of Bug #679927 +++

Since the two-stage throbber in bug 679927 requires some more code changes, as an initial step we will just replace the current single-stage throbber animation with the new animated icon from that bug.

The first patch just replaces the current throbber icon.  We will also need new backgrounds for endcaps on SSL sites that work better with the dark blue color of the new throbber.
Attachment #561964 - Flags: review?(mark.finkle)
Comment on attachment 561964 [details] [diff] [review]
part 1: new throbber asset

Did you try pngcrush on the files to remove any cruft?
Attachment #561964 - Flags: review?(mark.finkle) → review+
(Reporter)

Comment 2

7 years ago
Created attachment 562154 [details] [diff] [review]
part 2: new SSL endcaps

This uses the new endcap assets and colors from bug 679927.  It also removes some unused images from the honeycomb theme folder.

All images in both patches have been pngcrushed.
Attachment #562154 - Flags: review?(mark.finkle)
(Reporter)

Updated

7 years ago
Keywords: uiwanted
Whiteboard: [has patch]
Attachment #562154 - Flags: review?(mark.finkle) → review+
(Reporter)

Comment 4

7 years ago
https://hg.mozilla.org/mozilla-central/rev/96b970e6291b
https://hg.mozilla.org/mozilla-central/rev/6e370a64b8d1
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 9
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110925 Firefox/9.0a1 Fennec/9.0a1
Status: RESOLVED → VERIFIED
(Reporter)

Updated

7 years ago
Depends on: 689578
(Reporter)

Comment 6

7 years ago
Backed out because of Maemo perf regressions (bug 689578).  This can re-land after we verify that it does not regress performance on Android (waiting on bug 689350).

http://hg.mozilla.org/mozilla-central/rev/115e3576acf5
Status: VERIFIED → REOPENED
Depends on: 689350
Resolution: FIXED → ---
(Reporter)

Comment 7

7 years ago
We did not see similar regressions on Android, but Mark points out that this might be because the Android Tegra machines are dual-core while the Maemo N900 machines are single-core.  We need performance tests from single-core Android devices to make sure we are not regressing them.
(Reporter)

Updated

6 years ago
Assignee: mbrubeck → nobody
Gone native!
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.