Sometimes Virtual Keyboard is displayed while Hardware Keyboard is already used

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
7 years ago
7 years ago

People

(Reporter: carla.nadastean, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Whiteboard: [VKB][HKB])

(Reporter)

Description

7 years ago
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:8.0a2) Gecko/20110921 Firefox/8.0a2 Fennec/8.0a2
Device: Motorola DROID 2, HTC Desire Z
OS: Android 2.3

Steps to reproduce:
1. Open Hardware Keyboard. Device is in landscape mode.
2. Open Fennec app.
3. Tap on URL bar and browse to a webpage. (e.g. www.google.com)

Expected Result:
Virtual Keyboard is not displayed since Hardware Keyboard is used.

Actual Result:
Virtual Keyboard is displayed.
Please see also video:
http://www.youtube.com/user/qaioana#p/u/8/9zeGmadZdWY
Does this happen on Nightly as well?
Whiteboard: [VKB]

Updated

7 years ago
status-firefox8: --- → affected
(Reporter)

Comment 2

7 years ago
I was able to reproduce bug also on Nightly

Build ID:Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110926 Firefox/9.0a1 Fennec/9.0a1
Device: Motorola DROID 2
OS: Android 2.3
Version: Firefox 8 → Trunk
What software keyboard is this?
Looking at the video, it looks like the default SKB?  I think the key in the video was that the app was waken in portrait mode with the keyboard already open.  It's quite possible that the app was placed in the background in portrait position.

That's a real good test!
Hrm, I can't seem to reproduce, but the droid that I'm using is 2.2; it may have something to do with the slowness to respond.

Updated

7 years ago
Whiteboard: [VKB] → [VKB][HKB]
Can anybody reproduce this with the native UI builds from the birch branch?

Comment 7

7 years ago
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111122 Firefox/11.0a1 Fennec/11.0a1 - Native build
Device: HTC Desire Z, Motorola Droid 2
OS: Android 2.3

Cannot reproduce issue on latest nightly birch build.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.