Opening website from RSS: "Open in new tab" not available in context menu

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Sven C. Berger, Assigned: ewong)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20110902 Firefox/6.0.2 SeaMonkey/2.3.3
Build ID: 20110902180055

Steps to reproduce:

1. Opening RSS Feed article
2. rightclicking on website URL


Actual results:

Context-menu only offers single function (copy URL)


Expected results:

additional function: "Open in new tab"

Comment 1

6 years ago
Hmm. Works for me with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110930 SeaMonkey/2.7a1.

How are you "Opening RSS Feed article"? I tried from the preview pane and from the standalone message window.
(Reporter)

Comment 2

6 years ago
Created attachment 563808 [details]
Screenshot

I think I used what is called the preview pane. I've uploaded a screenshot where the context menu is encircled in red.

Comment 3

6 years ago
Ah I thought you meant a URL *in* the feed content. Confirmed with:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110930 SeaMonkey/2.7a1

For anyone who is interested in fixing this bug the context menu is in:
suite/mailnews/msgHdrViewOverlay.xul

See: function OpenBrowserWithMessageId() in:
suite/mailnews/mailContextMenus.js
For hints on how to implement this.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Whiteboard: [good first bug]
(Assignee)

Updated

6 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
(Assignee)

Comment 4

6 years ago
Created attachment 583049 [details] [diff] [review]
Added 'Open in New Tab' to RSS context menu popup. (v1)
Attachment #583049 - Flags: review?(iann_bugzilla)

Comment 5

6 years ago
There is no need to invent a new function. Please use openAsExternal() so that the window/tab/background prefs are respected.

> +  <menuitem label="&openInNewTab.label;" accesskey="&openInNewTab.accesskey;" oncommand="OpenInNewTab(document.popupNode)"/>

I think this could work:
... oncommand= "openAsExternal(document.popupNode.getAttribute("value")"

> +<!ENTITY openInNewTab.label                "Open in New Tab">
> +<!ENTITY openInNewTab.accesskey            "T">
If you use openAsExternal() the url might open in a new window instead depending on the preferences, so I suggest "Open in Browser".
(Assignee)

Comment 6

6 years ago
Created attachment 583409 [details] [diff] [review]
Added 'Open in Browser' to RSS context menu popup. (v2)
Attachment #583049 - Attachment is obsolete: true
Attachment #583049 - Flags: review?(iann_bugzilla)
Attachment #583409 - Flags: review?(iann_bugzilla)

Updated

6 years ago
OS: Windows XP → All
Hardware: x86 → All
Version: SeaMonkey 2.3 Branch → Trunk

Comment 7

6 years ago
Comment on attachment 583409 [details] [diff] [review]
Added 'Open in Browser' to RSS context menu popup. (v2)

Unfortunately, you got bit-rotted by Jens.

>+++ b/suite/locales/en-US/chrome/mailnews/msgHdrViewPopup.dtd
>+<!ENTITY openInBrowser.label               "Open in Browser">
>+<!ENTITY openInBrowser.accesskey           "p">
I think "O" would be a better accesskey here as it is available.

>+++ b/suite/mailnews/msgHdrViewOverlay.xul
>@@ -131,6 +131,9 @@
> 
> <menupopup id="copyUrlPopup">
>   <menuitem label="&copyLinkCmd.label;" accesskey="&copyLinkCmd.accesskey;" oncommand="CopyWebsiteAddress(document.popupNode)"/>
>+  <menuitem label="&openInBrowser.label;"
>+            accesskey="&openInBrowser.accesskey;"
>+            oncommand="openAsExternal(document.popupNode.getAttribute('value'))"/>
Nit: use ; at end of the ) within the oncommand.

I think "Open in Browser" should be the first option in the list, followed by Bookmark, followed by Copy Link.

r=me with those changes, probably worth getting a moa from Mnyromyr too
Attachment #583409 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 8

6 years ago
Created attachment 584247 [details] [diff] [review]
Added 'Open in Browser' to RSS context menu popup. (v3)
Attachment #583409 - Attachment is obsolete: true
Attachment #584247 - Flags: review+

Comment 9

6 years ago
Edmund, remember to ask for moa from Mnyromyr by using the sr? flag.
(Assignee)

Updated

6 years ago
Attachment #584247 - Flags: superreview?(mnyromyr)
(Assignee)

Comment 10

6 years ago
Created attachment 584913 [details] [diff] [review]
Added 'Open in Browser' to RSS context menu popup. (v4)
Attachment #584247 - Attachment is obsolete: true
Attachment #584247 - Flags: superreview?(mnyromyr)
Attachment #584913 - Flags: review?(iann_bugzilla)

Updated

6 years ago
Attachment #584913 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

6 years ago
Attachment #584913 - Flags: superreview?(mnyromyr)

Updated

6 years ago
Duplicate of this bug: 463897

Updated

6 years ago
Component: MailNews: General → MailNews: Message Display
QA Contact: mail → message-display

Updated

5 years ago
Attachment #584913 - Flags: superreview?(mnyromyr) → superreview+
(Assignee)

Comment 12

5 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/230f526f4fca
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.