Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 689025 - Language button has a label referencing location of
: Language button has a label referencing location of
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 9
Assigned To: Wesley Johnston (:wesj)
: 689092 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2011-09-25 06:25 PDT by Aaron Train [:aaronmt]
Modified: 2012-08-20 15:58 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---

Nightly (09/25) (148.17 KB, image/jpeg)
2011-09-25 06:25 PDT, Aaron Train [:aaronmt]
no flags Details
Patch (1.22 KB, patch)
2011-09-26 10:11 PDT, Wesley Johnston (:wesj)
mark.finkle: review+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-09-25 06:25:17 PDT
Created attachment 562293 [details]
Nightly (09/25)

Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110925 Firefox/9.0a1 Fennec/9.0a1

In preferences, the 'Language' button has a label with a value: chrome://global/locale/

See screenshot.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-25 21:31:24 PDT
*** Bug 689092 has been marked as a duplicate of this bug. ***
Comment 2 Wesley Johnston (:wesj) 2011-09-26 10:11:59 PDT
Created attachment 562464 [details] [diff] [review]

My original concern here was when users download and install a locale and then return to the Prefs pane. We don't have a nice language string to show, so instead we fall back to showing the locale code. Apparently when we're using auto-detection that can result in this strangeness?

This makes that fallback only happen if the pref has a user set value.

Alternatively, instead of listening for pref change notifications, I could fire off an observer notification from the locale picker when "Continue" (or Cancel, etc) was pressed that had the current selected locale name attached.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-26 10:19:13 PDT
Comment on attachment 562464 [details] [diff] [review]

>-    let selectedLocale = Services.prefs.getCharPref("general.useragent.locale");
>+    let selectedLocale = chrome.getSelectedLocale("browser");
>+    // the chrome locale may not have updated yet if the user is installing a new
>+    // locale. if the pref has a user set value, use it instead

Add a blank line before the comment
Comment 4 Matt Brubeck (:mbrubeck) 2011-09-26 14:32:54 PDT
Comment 5 Cristian Nicolae (:xti) 2011-09-27 05:25:18 PDT
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110927
Firefox/9.0a1 Fennec/9.0a1
Device: Acer ICONIA A500
OS: Android 3.1

Note You need to log in before you can comment on or make changes to this bug.