Last Comment Bug 689223 - content encoding error on https://irccloud.com on nightly Firefox Android mobile
: content encoding error on https://irccloud.com on nightly Firefox Android mobile
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
https://irccloud.com
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 11:21 PDT by Asa Dotzler [:asa]
Modified: 2012-08-02 05:06 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Asa Dotzler [:asa] 2011-09-26 11:21:34 PDT
When visiting https://irccloud.com using the latest nightly Fennec build on a Galaxy Tab and an Eee Pad Transformer, I get a "Problem loading page" with "Content Encoding Error"

I've tried spoofing other UAs with no effect. I've tried on a few different wi-fi networks (home and work) with no effect. I've tried many many reloads with no effect.
Comment 1 Patrick McManus [:mcmanus] 2011-09-26 12:32:44 PDT
hey asa,

when we trace this back we will very likely find that irccloud.com is sending two response values for some kind of security important header - like content-length, location, or content-disposition. (also possibly, an invalidly formatted content-length that we don't feel we can parse safely). The integrity of the http channel relies on them being consistent - a mismatch here is the core of most HTTP response smuggling attacks, which is why we reject it instead of trying to muddle through.

there is already a bug open saying the details/error need to be better.
Comment 2 Patrick McManus [:mcmanus] 2011-09-26 13:37:55 PDT
(In reply to Patrick McManus from comment #1)
> 
> when we trace this back we will very likely find that irccloud.com is

I was wrong. what I described was a different, but similar, error message and it had been on my mind lately. But this issue is 100% unrelated to what I erroneously described in comment 1.

Instead, irccloud.com is serving up in response to / a 8908 byte response without a content-type and labeled Content-Encoding: gzip .. however it is not a valid gzip file. Thus the rather literal "Content Encoding Error".

If you go to about:config and turn off compression negotiation the page loads fine (it sends a 50KB file, still without a content-type which we sniff as html.)

the server is one I have never heard of: misultin/0.9-dev

Interesting that it doesn't send gzip (either broken or valid) to the desktop - I'm not sure what it is sniffing to make that distinction, it isn't the UA string.

I don't think there is anything to fix on mozilla's side.. evangelism needed.
Comment 3 Asa Dotzler [:asa] 2011-09-26 17:59:54 PDT
Patrick, thank you for looking into this. I will see if I can find a contact at irccloud.
Comment 4 RJ 2011-10-07 08:58:13 PDT
I do the backend/server stuff for irccloud. We're now sending "Content-Type: text/html; charset=UTF-8" for the / page, and it's now working fine on the firefox nightly on my nexus s.

Feel free to CC me, or james@wheare.org (frontend/browser stuff for irccloud) on any future tickets.

Note You need to log in before you can comment on or make changes to this bug.