Last Comment Bug 689267 - Layout problems and "this.control is undefined" because prefs-uilanguage should not be type="menulist"
: Layout problems and "this.control is undefined" because prefs-uilanguage shou...
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 9
: All All
: -- normal (vote)
: Firefox 9
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
Depends on:
Blocks: 658278 669390
  Show dependency treegraph
 
Reported: 2011-09-26 13:30 PDT by Matt Brubeck (:mbrubeck)
Modified: 2013-12-10 10:00 PST (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (1.58 KB, patch)
2011-09-26 13:30 PDT, Matt Brubeck (:mbrubeck)
wjohnston2000: review+
Details | Diff | Review

Description Matt Brubeck (:mbrubeck) 2011-09-26 13:30:17 PDT
Created attachment 562521 [details] [diff] [review]
patch

Steps to reproduce:
1. Open the Fennec preferences.

Expected results: "Language" label and button are on the same line.
Actual results: "Language" label and button are on separate lines, and the following console errors appear:

reference to undefined property this.getElementsByTagName(this.getAttribute("type") == "radio" ? "radiogroup" : "menulist")[0]
chrome://mozapps/content/extensions/setting.xml
539
this.control is undefined
chrome://mozapps/content/extensions/setting.xml
492

This error was caused by a combination of bug 669390 and bug 658278.  Since this preference no longer contains a menulist, it should use the generic type="control" instead.
Comment 1 Matt Brubeck (:mbrubeck) 2011-09-26 14:32:25 PDT
https://hg.mozilla.org/mozilla-central/rev/b71570ffc968
Comment 2 Camelia Urian 2011-09-30 04:53:42 PDT
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a2)Gecko/20110929
Firefox/9.0a2 Fennec/9.0a2
Device: HTC Desire Z
OS: Android 2.3

Language and language button are displayed on same line and error from comment 1 is not displayed in the error console.

Note You need to log in before you can comment on or make changes to this bug.