Closed Bug 689286 Opened 9 years ago Closed 9 years ago

Pages don't complete loading until halted and reloaded [@ fixupSelectorsInMethodList ]

Categories

(Firefox :: General, defect)

7 Branch
x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: max_corvallis, Unassigned)

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110916091512

Steps to reproduce:

Click on link.


Actual results:

1. New tab appears, but page doesn't display. Appears to be "working."
2. User presses "stop loading," then "reload."
3. Completed page is displayed almost instantly.


Expected results:

Page should display without stop/reload.
This has happened for a while, but this time ff crashed while in the "can't finish" state (I think) and I'm hoping the crash report gives some clues:

ID: 964bf1e8-9c28-433d-abfb-90cef2110926

Is there a direct way to get on the cc list from a crash report, or is it necessary to make a report in bugzilla?
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
Crash Signature: [@ fixupSelectorsInMethodList ]
Keywords: crash, crashreportid
(In reply to Max from comment #1)
> This has happened for a while, but this time ff crashed while in the "can't
> finish" state (I think) and I'm hoping the crash report gives some clues:
> 
> ID: 964bf1e8-9c28-433d-abfb-90cef2110926
> 
> Is there a direct way to get on the cc list from a crash report, or is it
> necessary to make a report in bugzilla?

If you are asking how to look up the crash details, visit https://crash-stats.mozilla.com/query and plug in the ID, which yields https://crash-stats.mozilla.com/report/index/964bf1e8-9c28-433d-abfb-90cef2110926 ... which reveals your crash signature

0		@0xffff08b7	
1	libobjc.A.dylib	fixupSelectorsInMethodList	
2	libobjc.A.dylib	_class_getMethodNoSuper	
3	libobjc.A.dylib	_class_lookupMethodAndLoadCache	
4	libobjc.A.dylib	objc_msgSend	
5	Foundation	_NSOutOfMemoryErrorHandler	
6	CoreFoundation	__CFStringChangeSizeMultiple	
7	CoreFoundation	__CFStringAppendBytes	
8	CoreFoundation	_CFStringAppendFormatAndArgumentsAux	
9	CoreFoundation	_CFStringCreateWithFormatAndArgumentsAux	
10	CoreFoundation	CFStringCreateWithFormatAndArguments	
11	CoreFoundation	CFStringCreateWithFormat	
12	CoreFoundation	__CFDictionaryHandleOutOfMemory	
13	CoreFoundation	__CFDictionaryGrow	
14	CoreFoundation	CFDictionarySetValue	
15	IOKit	IOCFUnserializeparse	
16	IOKit	IOCFUnserialize	
17	IOKit	IORegistryEntryCreateCFProperties	
18	XUL	nsIdleServiceX::PollIdleTime	widget/src/cocoa/nsIdleServiceX.mm:73
19	XUL	nsIdleService::GetIdleTime	widget/src/xpwidgets/nsIdleService.cpp:256
20	XUL	nsIdleService::CheckAwayState	widget/src/xpwidgets/nsIdleService.cpp:321
Severity: normal → critical
Keywords: crashreportid
Summary: Pages don't complete loading until halted and reloaded → Pages don't complete loading until halted and reloaded [@ fixupSelectorsInMethodList ]
Tim: I got ok results in safe mode and empty profile. The only addon I'm using now in my regular profile is Adblock Plus. (I got rid of all the other addons to fix memory leak problems.) I added a filter to Adblock Plus recently to try to avoid facebook because when a page wouldn't load, the status often said, "Waiting for Facebook..."

I just added another filter called Antisocial to Adblock Plus, a filter aimed at junk like facebook, and my standard big bookmark folder of news sites loaded ok. So I don't know exactly what the problem was, or if it's fixed, or just intermittent.

I also don't know if any of this relates to the crash.

Wayne: I was wondering whether there is a way to automatically get cc'd on a crash report. But it seems one must create the bug report oneself and then reference the crash report?
(In reply to Max from comment #4)
> Wayne: ... it seems one must create the bug report oneself and then
> reference the crash report?

correct

so, presumably this was caused by an addon, or something funky in profile
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.