Last Comment Bug 689337 - Desktop notification interfaces should not be marked 'function'
: Desktop notification interfaces should not be marked 'function'
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 15:25 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2012-01-25 07:34 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.13 KB, patch)
2012-01-13 01:38 PST, :Ms2ger (⌚ UTC+1/+2)
khuey: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-09-26 15:25:34 PDT

    
Comment 1 Doug Turner (:dougt) 2011-09-26 20:26:15 PDT
why?
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-09-27 04:39:14 PDT
Because 'function' means you can pass in a JS function and XPConnect will coerce it into the interface.  Both these interfaces are only implemented in C++, so this is unnecessary.
Comment 3 Doug Turner (:dougt) 2011-09-27 07:40:00 PDT
yes, 'function' should be removed.
Comment 4 Doug Turner (:dougt) 2012-01-12 14:02:05 PST
i am not working on these right now.  resetting assignee.
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-01-13 01:38:01 PST
Created attachment 588344 [details] [diff] [review]
Patch v1
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-01-25 07:34:12 PST
https://hg.mozilla.org/mozilla-central/rev/0e4cd20fd801

Note You need to log in before you can comment on or make changes to this bug.