Last Comment Bug 689349 - Don't Suggest Values for Password Text Boxes
: Don't Suggest Values for Password Text Boxes
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 9
: Other Android
: -- normal (vote)
: Firefox 10
Assigned To: Lucas Rocha (:lucasr)
:
Mentors:
http://mail.mozilla.com
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 15:52 PDT by Michael Coates [:mcoates] (acct no longer active)
Modified: 2011-10-13 11:58 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Example picture showing suggested text for password box (209.61 KB, image/jpeg)
2011-09-26 15:52 PDT, Michael Coates [:mcoates] (acct no longer active)
no flags Details
Don't suggest values for password text boxes (1.01 KB, patch)
2011-09-27 07:54 PDT, Lucas Rocha (:lucasr)
mark.finkle: review+
Details | Diff | Review

Description Michael Coates [:mcoates] (acct no longer active) 2011-09-26 15:52:22 PDT
Running nightly on Galaxy S tablet. Version 9.0a1

Issue
Clicking into a password field box will bring up the tool tip gui and suggest other values that have been entered into other text boxes. Note: it does not appear to suggest any password values, just other text box values.

Steps to reproduce:
1. Go to a website, submit a form that contains a text box
2. Go to another page on that website and single click into the password box. The auto suggest should show the text entered from the other form.

Expected Behavior
Password fields will never suggest values
Comment 1 Michael Coates [:mcoates] (acct no longer active) 2011-09-26 15:52:59 PDT
Created attachment 562565 [details]
Example picture showing suggested text for password box
Comment 2 Lucas Rocha (:lucasr) 2011-09-27 07:54:32 PDT
Created attachment 562768 [details] [diff] [review]
Don't suggest values for password text boxes
Comment 3 Lucas Rocha (:lucasr) 2011-09-27 08:11:04 PDT
*** Bug 689558 has been marked as a duplicate of this bug. ***
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-27 08:53:40 PDT
I think we'll want this on Fx9, so tracking. We can request approval for aurora, once it lands.
Comment 5 Lucas Rocha (:lucasr) 2011-09-28 09:52:03 PDT
Landed: http://hg.mozilla.org/integration/mozilla-inbound/rev/638433a972a3
Comment 6 Michael Wu [:mwu] 2011-09-29 01:28:56 PDT
https://hg.mozilla.org/mozilla-central/rev/638433a972a3
Comment 7 Aaron Train [:aaronmt] 2011-10-13 11:58:33 PDT
Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/20111013 Firefox/10.0a1 Fennec/10.0a1

Note You need to log in before you can comment on or make changes to this bug.