Closed Bug 68938 Opened 19 years ago Closed 19 years ago

Problem with Mozilla Classic skin & gtk themes

Categories

(Core Graveyard :: Skinability, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 67448

People

(Reporter: hramrach, Assigned: dbaron)

Details

Attachments

(4 files)

When I tried out the LCARS theme which is shipped with GTK in RedHat6 packege,
and Mozilla Classic skin Mozilla looked quite bad. When I upgraded from 0.7 to
2001021506 some problems seem to be fixed but other persist. I compare the
behavior of GTK widgets with the behavior of Mozilla ones. There are three reasons 
   i)  It shows how the GTK widgets use the colors so that they are usable 
   ii) When you use the colors you should use other settings as well because the
widgets may depend on them. 
   iii)Using all possible settings from the GTK theme really integrates Mozilla
into the UI of the system which should be the goal of the Classic skin (at least
I think so).
1) Mozilla style scrollbars are almost all black. They don't have any rollover
effect which makes the GTK style scrollbars more usable. GTK style scrollbars
found in the documnts (eg. the bugzilla query page) are quite visible but have
no rollover effect either.
2)Buttons appear in inverted colors.They use different rollover effect that
makes the text unreadable by changing it's color to blue (don't know where the
blue color is taken from) instead of changing button background to active which
makes the text more readable in GTK apps.
3)In preferences, the title background bitmap is almost the same color as the
title text.
4)Page source shows nothing because of bad colors.

The conclusion is that I experience differences between behavior of mozilla
widgets and widgets of other GTK apps which makes some of the mozilla widgets
hard to use. I would expect Mozilla Classic skin to mimic the GTK as closely as
possible (or any other widget set).
reporter: we need at least a picture of a normal app window. ideally you should 
give us a list of the properties and their values [for this theme], as well as 
guesses as to what we are doing [actually, you don't need to guess, you can 
look at lxr.mozilla.org and read what we are doing].
I didn't create the theme nor I'm familiar with GTK theming. The theme is quite
dynamic: The controls change colors dramatically when you point at them with
your mouse. I think it's at least partially achieved by exchanging background
bitmaps. 
On the other hand, the buttons appear black on violet while mozilla has buttons
in voilet on black. If it just lacked the background bitmap they would be black
on black :)
I'll take this bug, since my latest patch on bug 67448 should fix it.  But could
you also attach a screenshot of what the old Mozilla (0.7) looked like?
Assignee: ben → dbaron
Status: UNCONFIRMED → NEW
Ever confirmed: true
s/fix it/improve it/

*** This bug has been marked as a duplicate of 67448 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
vrfy dup
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.