Last Comment Bug 689685 - All devtools strings files should contain an 'optional English' note.
: All devtools strings files should contain an 'optional English' note.
Status: RESOLVED FIXED
[fixed-in-fx-team][strings]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 11
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-27 12:08 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-01-23 03:12 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
upload 1 (6.19 KB, patch)
2011-11-17 06:49 PST, Joe Walker [:jwalker] (needinfo me or ping on irc)
mihai.sucan: review+
past: review+
mratcliffe: review+
rcampbell: review+
Details | Diff | Splinter Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-09-27 12:08:27 PDT
Many locales will not have the resources with which to translate all of developer tools, and in many locales, the best language may be English anyway.

We need to inform localizers that they should make a decision about translation and use that consistently across all developer tools.

Axel has suggested that we use the following string:

# The correct localization of this file might be to keep it in
# English, or another language commonly spoken among web developers.
# You want to make that choice consistent across the developer tools.
# A good criteria is the language in which you'd find the best
# documentation on web development on the web.
Comment 1 Dave Camp (:dcamp) 2011-10-27 08:54:23 PDT
We're doing developer tool prioritization, filter on 'brontozaur'
to ignore the spam.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-10-27 12:37:37 PDT
I'd like to bump up the priority on this. Which I guess means I need to do the work...
Comment 3 Cedric Vivier [:cedricv] 2011-11-03 02:00:20 PDT
(In reply to Joe Walker from comment #2)
> I'd like to bump up the priority on this. Which I guess means I need to do
> the work...

I've done in for the Style Editor. Will be in next 583041 patch.
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-17 06:49:35 PST
Created attachment 575175 [details] [diff] [review]
upload 1

I r?ed virtually everyone who's recently edited these files as much as an FYI as anything.
Comment 5 Panos Astithas [:past] 2011-11-17 23:57:12 PST
Comment on attachment 575175 [details] [diff] [review]
upload 1

Review of attachment 575175 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, this reminder helped me fix a similar issue in the debugger in bug 703268.
Comment 6 Rob Campbell [:rc] (:robcee) 2011-11-18 11:42:33 PST
Comment on attachment 575175 [details] [diff] [review]
upload 1

+# The correct localization of this file might be to keep it in
+# English, or another language commonly spoken among web developers.

we can probably drop the ", or another language..." verbeage. We really just want to emphasize that it's ok to leave some parts in English if they're not easily-translateable.
Comment 7 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-18 12:29:22 PST
(In reply to Rob Campbell [:rc] (robcee) from comment #6)
> Comment on attachment 575175 [details] [diff] [review] [diff] [details] [review]
> upload 1
> 
> +# The correct localization of this file might be to keep it in
> +# English, or another language commonly spoken among web developers.
> 
> we can probably drop the ", or another language..." verbeage. We really just
> want to emphasize that it's ok to leave some parts in English if they're not
> easily-translateable.

I think the point could be that the Romansh locale would probably use German for developer tools rather than English (for example) since Romansh speakers tend to come from the German speaking part of Switzerland.

Is it worth going back to Axel about?
Comment 8 Axel Hecht [:Pike] 2011-11-18 12:41:16 PST
I'm here, sleepless in Kuala Lumpur.

Yes, other language is good to have. I'm in particular thinking about regions like Senegal and Wolof Language, where French is an order of magnitude better as fallback language than English.
Comment 9 Rob Campbell [:rc] (:robcee) 2011-11-18 13:55:31 PST
ok, thanks for the feedback. Concern rescinded! :)
Comment 10 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-21 08:34:32 PST
https://tbpl.mozilla.org/?tree=Try&rev=28134b5df88a
Comment 11 Rob Campbell [:rc] (:robcee) 2011-11-21 13:01:20 PST
https://hg.mozilla.org/integration/fx-team/rev/81dd92e08196
Comment 12 Rob Campbell [:rc] (:robcee) 2011-11-22 06:38:06 PST
https://hg.mozilla.org/mozilla-central/rev/81dd92e08196

Note You need to log in before you can comment on or make changes to this bug.