Last Comment Bug 689804 - Disable orion in scratchpad on aurora
: Disable orion in scratchpad on aurora
Status: VERIFIED FIXED
[qa!]
: verified-aurora, verified-beta
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: 9 Branch
: x86 All
: -- normal (vote)
: ---
Assigned To: Dave Camp (:dcamp)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-27 17:22 PDT by Dave Camp (:dcamp)
Modified: 2011-11-25 02:38 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
Disable orion on aurora. (809 bytes, patch)
2011-09-27 17:24 PDT, Dave Camp (:dcamp)
rcampbell: review+
jst: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Dave Camp (:dcamp) 2011-09-27 17:22:47 PDT
Orion has some problems (particularly cut-and-paste related) that warrant disabling it for Firefox 9.
Comment 1 Dave Camp (:dcamp) 2011-09-27 17:24:25 PDT
Created attachment 562921 [details] [diff] [review]
Disable orion on aurora.
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-11-21 17:25:32 PST
Is there something QA can do to verify this?
Comment 4 Rob Campbell [:rc] (:robcee) 2011-11-23 02:28:42 PST
in a default profile in Firefox beta, open a Scratchpad, verify that the text is not colored.

Or, open about:config and verify that devtools.editor.component is textarea instead of orion.

This is intended to be the reverse in Aurora 10. devtools.editor.component should be orion there.
Comment 5 Paul Silaghi, QA [:pauly] 2011-11-25 02:23:25 PST
devtools.editor.component is "textarea" on:
Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (X11; Linux i686; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0

devtools.editor.component is "orion" on:
Mozilla/5.0 (Windows NT 6.1; rv:10.0a2) Gecko/20111123 Firefox/10.0a2
Mozilla/5.0 (Windows NT 5.1; rv:10.0a2) Gecko/20111123 Firefox/10.0a2
Mozilla/5.0 (X11; Linux i686; rv:10.0a2) Gecko/20111124 Firefox/10.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a2) Gecko/20111124 Firefox/10.0a2

setting the bug as verified fixed

Note You need to log in before you can comment on or make changes to this bug.