Last Comment Bug 689897 - text-oveflow:ellipsis hides non-text elements that overflow (and shows ellipsis)
: text-oveflow:ellipsis hides non-text elements that overflow (and shows ellipsis)
Status: RESOLVED DUPLICATE of bug 690187
:
Product: Core
Classification: Components
Component: Layout: Block and Inline (show other bugs)
: 7 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 312156
  Show dependency treegraph
 
Reported: 2011-09-28 04:05 PDT by Alex Gyoshev
Modified: 2011-12-14 17:15 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex Gyoshev 2011-09-28 04:05:58 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922153450

Steps to reproduce:

I placed a wide inline-block element in a smaller container with text-overflow:ellipsis. See http://jsfiddle.net/4y2N6/


Actual results:

The inner element was hidden and there was an ellipsis in the outer element.


Expected results:

Since the inner element wasn't text-related, the text-overflow property shouldn't have been triggered.
Comment 1 Mats Palmgren (vacation) 2011-09-28 04:46:32 PDT
This is the correct rendering per the relevant specs:

http://dev.w3.org/csswg/css3-ui/#text-overflow
"... implementations must hide characters and atomic inline-level elements at the applicable edge(s) of the line as necessary to fit the ellipsis/string"

and an inline-block is "atomic inline-level":

http://www.w3.org/TR/CSS21/visuren.html#inline-boxes
"Inline-level boxes that are not inline boxes (such as replaced inline-level elements, inline-block elements, and inline-table elements) are called atomic inline-level boxes because they participate in their inline formatting context as a single opaque box."
Comment 2 j.j. 2011-10-14 08:57:54 PDT
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111014 Firefox/10.0a1
Not fixed with bug 684266
Comment 3 j.j. 2011-12-14 17:15:36 PST
The specification changed an this might be fixed soon.

*** This bug has been marked as a duplicate of bug 690187 ***

Note You need to log in before you can comment on or make changes to this bug.