Last Comment Bug 689928 - White space in the left side of the tab bar
: White space in the left side of the tab bar
Status: VERIFIED DUPLICATE of bug 691541
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 9
: ARM Android
: -- normal (vote)
: Firefox 10
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
:
Mentors:
Depends on:
Blocks: 678480
  Show dependency treegraph
 
Reported: 2011-09-28 07:00 PDT by Andreea Pod
Modified: 2013-06-20 11:25 PDT (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot1 (56.15 KB, image/png)
2011-09-28 07:00 PDT, Andreea Pod
no flags Details
screenshot2 (71.96 KB, image/png)
2011-09-28 07:02 PDT, Andreea Pod
no flags Details
patch (1.06 KB, patch)
2011-10-07 14:08 PDT, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
mark.finkle: approval‑mozilla‑aurora-
Details | Diff | Splinter Review
Nightly (10/11) (10.45 KB, image/jpeg)
2011-10-11 07:12 PDT, Aaron Train [:aaronmt]
no flags Details

Description Andreea Pod 2011-09-28 07:00:24 PDT
Created attachment 563056 [details]
screenshot1

Mozilla /5.0 (Android;Linux armv7l;rv:10.0a1) Gecko/20110928 Firefox/10.0a1 Fennec/10.0a1
Device: LG Optimus 2X (Android 2.2)

Steps to reproduce:
1. Open Fennec with a new profile
2. Look at the left side of the screen while the first-run animation is running

Actual result:
you can see a white space from top to bottom (screenshot1)

Expected results:
no white spaces in the sidebars

Notes:
- the page is not rendered correctly in the left side also after you close and open the browser(screenshot2)
- reproducible on Aurora too: Mozilla /5.0 (Android;Linux armv7l;rv:9.0a2) Gecko/20110928 Firefox/9.0a2 Fennec/9.0a2
Comment 1 Andreea Pod 2011-09-28 07:02:24 PDT
Created attachment 563058 [details]
screenshot2
Comment 2 Aaron Train [:aaronmt] 2011-09-28 07:13:29 PDT
I don't see this on my Galaxy SII, nor a Nexus S. Can you trace a regression?
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-28 07:26:22 PDT
I see this on my Nexus One and Galaxy Tab (7")

My guess is it's either a regression from bug 678480 or bug 686417. Can we try nightlies to find the regression range?
Comment 4 Matt Brubeck (:mbrubeck) 2011-09-28 14:23:02 PDT
I can't reproduce this in desktop Fennec, even after selecting the Froyo skin and setting layout.css.dpi=240 in prefs.js.
Comment 5 Matt Brubeck (:mbrubeck) 2011-09-28 14:39:54 PDT
I also can't reproduce this on T-Mobile G2 (Android 2.3) running the latest trunk Nightly 10.0a1 (20110928).
Comment 6 Matt Brubeck (:mbrubeck) 2011-09-28 14:48:00 PDT
I do see this on Samsung Verizon Galaxy Tab 7" (Android 2.2).
Comment 7 Andreea Pod 2011-09-29 00:51:09 PDT
This started happening since bug 678480 was fixed.

Last build that wasn't with this problem:
http://hg.mozilla.org/mozilla-central/rev/259d1556c221

First build with this problem:
http://hg.mozilla.org/mozilla-central/rev/c71229984353

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=259d1556c221&tochange=c71229984353
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-03 19:42:24 PDT
*** Bug 691541 has been marked as a duplicate of this bug. ***
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-06 10:28:37 PDT
Who can work on this? It's needed in Aurora ASAP.
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-07 14:08:02 PDT
Created attachment 565647 [details] [diff] [review]
patch

This patch removes the fixed width/height in browser.xul causing less resizes. This fixes the content offset problem and might even help startup a tiny bit.

Test build is here:
http://people.mozilla.com/~mfinkle/fennec/fennec-10.a1-nofixedsize.apk
Comment 11 Matt Brubeck (:mbrubeck) 2011-10-07 19:39:45 PDT
Comment on attachment 565647 [details] [diff] [review]
patch

Nominating for Aurora 9.  This is a low-risk mobile only change that fixes a user-visible regression in the first-run animation on Android 2.2 devices.  The change just removes a hard-coded size from our main XUL window so that it will not need to resize again during startup.  (The hard-coded size has always been useful only on desktop Fennec builds.)
Comment 12 Matt Brubeck (:mbrubeck) 2011-10-07 20:03:48 PDT
https://hg.mozilla.org/mozilla-central/rev/194720ba054f
Comment 13 Aaron Train [:aaronmt] 2011-10-11 07:12:15 PDT
Created attachment 566208 [details]
Nightly (10/11)

This is still visible on (10/11 Nightly); albeit the thin line is now grey.
Comment 14 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-11 08:59:10 PDT
The fix for this has landed and won't be backed out. It did fix the issues for personal builds. We are working through the issues with nightly builds in bug 691541.

Let's leave this bug and move to bug 691541.

Not sure if FIXED or DUPE is better for this one. Choosing DUPE for now.

*** This bug has been marked as a duplicate of bug 691541 ***
Comment 15 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-11 14:35:07 PDT
Comment on attachment 565647 [details] [diff] [review]
patch

This hasn't actually fixed the problem on nightlies.

Note You need to log in before you can comment on or make changes to this bug.