Backgrounds for rows conflict with rowspanned cell backgrounds.

VERIFIED FIXED in mozilla0.9.5

Status

()

defect
--
major
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: tyler, Assigned: karnaze)

Tracking

Trunk
mozilla0.9.5
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+,Has review/super-review waiting for approval for branch check in, )

Attachments

(3 attachments)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8) Gecko/20010215
BuildID:    2001021508

The first rowspanning column (used as a border to the table) disappears.

Reproducible: Always
Steps to Reproduce:
1. Open the page with the browser.

Actual Results:  The column is missing.

Expected Results:  The column should be displayed.

This is a standard mode problem.  It displays correctly in quirks mode.
It has to do with the layering of the background colours.  The row background
colour is being written overtop of the rowspanning table cell when it should be
underneath.  Also the rows colour is not being fully extended across the table,
but is being truncated by the second rowspanning table cell.
Posted file Reduced test case.
Confirming on 2001021304 on Win2k.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA contact update
QA Contact: chrisd → amar
Blocks: 46268
Analysis: we draw first the table background then the first row with all its
childs and the then second row with all its childs and.... The both rowspan's
are drawn before the next row is drawn. This contradicts the table coloring
model from the css2 spec. 
No longer blocks: 46268
Blocks: 4510
Status: NEW → ASSIGNED
r= savulov (wow, huge job)
sr=waterson
*** Bug 62240 has been marked as a duplicate of this bug. ***
Nominating nsbranch, topembed. 
Keywords: nsbranch, patch, topembed
Severity: normal → major
Target Milestone: --- → mozilla0.9.5
Marking nsbranch+, removing topembed keyword
Keywords: nsbranch, topembednsbranch+
does this have a R= and SR =. Pls have it marked in the patch status.
Attachment #45112 - Flags: superreview+
Attachment #45112 - Flags: review+
Updated status
Whiteboard: Has review/super-review waiting for approval for branch check in
karnaze - let's get into the trunk, and pls call into to PDT tomorrow afternoon.
if you could some other people to test, that would be nice too.
Check it into the branch, and get someone on Lisa's team to test.
Whiteboard: Has review/super-review waiting for approval for branch check in → PDT+,Has review/super-review waiting for approval for branch check in
The patch has been checked into the trunk and the m0.9.4 branch.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
I will check this on 2001-09-21(tommorow) branch and mark this verified

 The patch did fix the problem.. The background rows are drawn correctly in the
new branch build 2001-09-21-05-0.9.4
Verified on build ID# 20010921
Platform : WIN2K
Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.