###!!! ABORT: aRelevantLinkVisited should only be set when we have a separate style: 'aRulesIfVisited || !aRelevantLinkVisited', file nsStyleContext.cpp, line 179

RESOLVED DUPLICATE of bug 575675

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 575675
7 years ago
4 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({assertion, testcase})

Trunk
x86_64
Linux
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 563184 [details]
testcase 1 (requires that you've visited bug page for bug 641731)

STR:
 1. Load attached testcase in a debug mozilla-central build.

ACTUAL RESULTS:
{
###!!! ABORT: aRelevantLinkVisited should only be set when we have a separate style: 'aRulesIfVisited || !aRelevantLinkVisited', file ../../../mozilla/layout/style/nsStyleContext.cpp, line 179
}

See also bug 575675, filed on another instance of this abort firing for XUL content.

(NOTE: The attached testcase is "testcase 2" from bug 641731.  I just discovered this while starting to work on that bug.)
Comment on attachment 563184 [details]
testcase 1 (requires that you've visited bug page for bug 641731)

(note: the bug only reproduces if the link in the embedded SVG is visited. In the case of the initial testcase I attached, that link is bug 641731)
Attachment #563184 - Attachment description: testcase 1 → testcase 1 (requires that you've visited bug page for bug 641731)
Created attachment 563185 [details]
reduced testcase 1 (requires that you've visited this page)

Here's a reduced testcase, whose link is to this bug page here. (so, it'll only repro if you've visited this bug page in your testing profile)
Attachment #563184 - Attachment is obsolete: true
(In reply to Daniel Holbert [:dholbert] from comment #1)
> (note: the bug only reproduces if the link in the embedded SVG is visited.

Due to the above-quoted note, this bug will likely become WFM once we've fixed bug 641731 (completely ignoring visited status in SVG-as-an-image).
This is actually the same underlying problem as bug 575675.

In particular, the preference stylesheet is not set up in SVG-as-image documents because mDocument->GetWindow() returns null in PresShell::SetPreferenceStyleRules.

Then the reasoning in bug 575675 comment 9 follows.
Depends on: 575675
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 575675
Resolution: --- → DUPLICATE
Duplicate of bug: 575675
(duping per bug 575675 comment 45, which suggests that we just remove the assertion & dupe all bugs on it failing to that bug)
You need to log in before you can comment on or make changes to this bug.