Last Comment Bug 690196 - Google's Blogspot thinks Firefox 10 is an unsupported mobile browser
: Google's Blogspot thinks Firefox 10 is an unsupported mobile browser
Status: RESOLVED WORKSFORME
: qawanted
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: All All
: -- normal
: ---
Assigned To: english-us
:
Mentors:
http://gmailblog.blogspot.com/
Depends on:
Blocks: uafx10
  Show dependency treegraph
 
Reported: 2011-09-28 18:32 PDT by Wes Kocher (:KWierso)
Modified: 2015-04-19 23:39 PDT (History)
12 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Wes Kocher (:KWierso) 2011-09-28 18:32:53 PDT
Blogspot's doing bad version sniffing on the new Firefox 10 Nightly builds, and they should stop.
Comment 1 Chris Lawson (gone) 2011-09-28 18:38:01 PDT
Would this be another example of code that's only looking for the first digit after "Firefox/" in the UA string?

If so, it might be worth opening a tracker for this type of bug, as this is the second one in three days I've seen.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-09-29 04:55:41 PDT
I've raised the issue with our contacts at Google.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-09-29 06:54:19 PDT
Google is on it.
Comment 4 Henri Sivonen (:hsivonen) 2011-09-30 00:30:56 PDT
Commenting on http://robert.ocallahan.org/2011/09/shifts-in-promoting-open-web.html didn't work for me. Maybe the same sniffer problem?
Comment 5 Jim Jeffery not reading bug-mail 1/2/11 2011-10-02 01:56:49 PDT
Google seems to have fixed their problem, now WFM.

The link in comment #4 also WFM.


Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111001 Firefox/10.0a1
Comment 6 NVD 2011-10-02 02:43:48 PDT
This is definitely not fixed. Clear out all your Blogger/Blogspot cookies and visit the link again. 

It still says: 

"Dynamic Views in Blogger require the use of a modern browser, and are not currently supported on mobile devices.
You can visit a non-dynamic version of this blog, continue unsupported, or upgrade your browser by clicking on one of the links below."
Comment 7 Justin Lebar (not reading bugmail) 2011-10-02 07:15:25 PDT
Indeed, NVD is right.
Comment 8 Atul Aggarwal 2011-10-10 21:56:47 PDT
I don't think this has anything to do with platform. I am also able to reproduce this issue on ubuntu.
Comment 9 Alex Keybl [:akeybl] 2011-11-28 12:51:21 PST
This doesn't occur for me - adding qawanted and tracking-firefox10 nonetheless. Let's verify that this is fixed.
Comment 10 Wes Kocher (:KWierso) 2011-11-28 13:00:04 PST
I don't see this anymore either. (Looks like the whole blog has had a redesign since I last checked up on it a month or so back, maybe it was fixed as part of that?)
Comment 11 Christopher Blizzard (:blizzard) 2011-12-08 12:38:31 PST
Marking fixed based on comment and personal testing.  Let me know if you still see the message.

Note You need to log in before you can comment on or make changes to this bug.