eventtracer interferes with goQuitApplication on leopard

RESOLVED FIXED in mozilla10

Status

()

Toolkit
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: alice, Assigned: ted)

Tracking

unspecified
mozilla10
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
When the eventtracer tool is enabled goQuitApplication (part of the pageloader bundle) causes the browser to freeze instead of quit cleanly.

This is only on leopard test boxes.
(Reporter)

Updated

7 years ago
Blocks: 631571
I only have 10.6 here, so I can't reproduce this. Can you use Activity Monitor and sample the process when it's hung?
(Reporter)

Comment 2

7 years ago
http://pastebin.mozilla.org/1339490

I've been testing this on tools-r3-leopard-001, which is an ateam test box which I can give you access to - since I don't see any smoking gun in the sample process output.
Looks like it's sitting and waiting for the background thread to exit:
1202 mozilla::ShutdownEventTracing()

We must exit the event loop differently on Leopard somehow, such that the last event that the background thread sends doesn't get processed.
I reproduced the hang on that same Leopard slave. I pushed a patch to try, I'll test with those builds when they become available:
http://hg.mozilla.org/try/pushloghtml?changeset=6d5f900ee3da
Assignee: nobody → ted.mielczarek
Created attachment 567490 [details] [diff] [review]
ensure that we unstick the event tracing thread when shutting down

I tested the try build on a 10.5 machine, and it worked fine. This patch just makes us signal the event tracer thread during shutdown, so that it doesn't get hung if it fires one last tracer event that never gets serviced.
Attachment #567490 - Flags: review?(benjamin)

Updated

7 years ago
Attachment #567490 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/mozilla-central/rev/6b83e2e33b5a
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
You need to log in before you can comment on or make changes to this bug.