Copy unavailable in View Source at first.

VERIFIED FIXED in Future

Status

()

Core
Editor
P4
major
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: hirata masakazu, Assigned: Doron Rosenberg (IBM))

Tracking

({helpwanted, regression})

Trunk
Future
helpwanted, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This goes back at least to 2001021208.
View Source
Select All
Now, Copy is unavailable, and Command+C does not work either.
2001021508 MTrunk.

Comment 1

17 years ago
it's working for us on mac and win32, if you still see this problem -- reopen
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Summary: Copy unavailable in View Source → Copy unavailable in View Source

Comment 2

17 years ago
verified in 2/16 build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
It's back! 2001022694.
Status: VERIFIED → REOPENED
Keywords: regression
OS: Mac System 8.5 → Mac System 9.x
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

17 years ago
To be more precise, Copy does not work at the first try.
If you copy a text in Browser window first, then it works in View Source window too.
Summary: Copy unavailable in View Source → Copy unavailable in View Source at first.

Comment 5

17 years ago
this should probably go to law
Assignee: beppe → law
Status: REOPENED → NEW

Comment 6

17 years ago
The problem is that view source is really a "menuless" window, but on mac, I
think it just inherits the menubar of the "hidden" window, which is a copy of
the navigator menubar. I wouldn't be surprised that you need a navigator window
to enable the menu item. Supposedly doronr is whipping up a menubar for the view
source window. Reassigning to pchen, marking nsbeta1+, p3, mozilla0.9.1
Assignee: law → pchen
Keywords: nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 7

17 years ago
yes, i have one actually done (bug 63026). Still doing some refinements, but it
should land in the next week or so hopefully. 
as discussed in team meeting, moving all Nav+ team members nsbeta1+ P3 bugs from 
mozilla0.9.1 to mozilla0.9.2. 
Target Milestone: mozilla0.9.1 → mozilla0.9.2
nav triage: moving to Future. helpwanted. 
Keywords: helpwanted
Priority: P3 → P4
Target Milestone: mozilla0.9.2 → Future
(Assignee)

Comment 10

17 years ago
-> me, depends on 63026

Assignee: pchen → doronr
Depends on: 63026
OS: Mac System 9.x → All
Hardware: Macintosh → All
(Reporter)

Comment 11

17 years ago
I can confirm this has been fixed in 2001061305 trunk.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.