Last Comment Bug 690566 - ShadowCanvasLayer::RenderLayer doesn't ApplyFilter for each tile
: ShadowCanvasLayer::RenderLayer doesn't ApplyFilter for each tile
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Ali Juma [:ajuma]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 15:02 PDT by Ali Juma [:ajuma]
Modified: 2011-10-06 03:48 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make ShadowCanvasLayer::RenderLayer apply filter for each tile (1.20 KB, patch)
2011-09-29 15:05 PDT, Ali Juma [:ajuma]
jmuizelaar: review-
Details | Diff | Splinter Review
Associate filters with texture images. (16.55 KB, patch)
2011-10-04 13:44 PDT, Ali Juma [:ajuma]
jmuizelaar: review+
Details | Diff | Splinter Review

Description Ali Juma [:ajuma] 2011-09-29 15:02:04 PDT
It should really ApplyFilter after each texture tile is bound.
Comment 1 Ali Juma [:ajuma] 2011-09-29 15:05:19 PDT
Created attachment 563564 [details] [diff] [review]
Make ShadowCanvasLayer::RenderLayer apply filter for each tile
Comment 2 Benoit Girard (:BenWa) 2011-09-29 15:30:29 PDT
Comment on attachment 563564 [details] [diff] [review]
Make ShadowCanvasLayer::RenderLayer apply filter for each tile

Passing the review along. We worked together on that patch.
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-10-03 08:40:36 PDT
Comment on attachment 563564 [details] [diff] [review]
Make ShadowCanvasLayer::RenderLayer apply filter for each tile

we should see if we can associate the filter more closely with the texture image, because it is texture state and not glcontext state.
Comment 4 Ali Juma [:ajuma] 2011-10-04 13:44:36 PDT
Created attachment 564659 [details] [diff] [review]
Associate filters with texture images.

In addition to associating filters with texture images, this also moves ApplyFilter from LayerOGL to GLContext and renames it to ApplyFilterToBoundTexture.
Comment 5 Jeff Muizelaar [:jrmuizel] 2011-10-04 13:53:46 PDT
Comment on attachment 564659 [details] [diff] [review]
Associate filters with texture images.

Review of attachment 564659 [details] [diff] [review]:
-----------------------------------------------------------------

I think this is clearer than before. I'd be interested to hear what others think.
Comment 7 Ed Morley [:emorley] 2011-10-06 03:48:57 PDT
https://hg.mozilla.org/mozilla-central/rev/cdcfb799ff50

Note You need to log in before you can comment on or make changes to this bug.