Intermittent TEST-UNEXPECTED-FAIL | leaked 16, 32, or 96 bytes during test execution | leaked 1, 2, or 3 instances of GenericFactory

RESOLVED DUPLICATE of bug 684887

Status

()

defect
RESOLVED DUPLICATE of bug 684887
8 years ago
6 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({intermittent-failure, memory-leak})

9 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

8 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=6575693&tree=Firefox
Rev3 WINNT 6.1 mozilla-central debug test mochitest-other on 2011-09-27 08:53:37 PDT for push ade33e515f46

and

https://tbpl.mozilla.org/php/getParsedLog.php?id=6615139&tree=Firefox
Rev3 Fedora 12 mozilla-central debug test mochitest-other on 2011-09-29 14:55:34 PDT for push af3668a89015

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 2182

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          31        0       10        0 (    1.20 +/-     0.70)       16        0 (    1.56 +/-     0.84)

nsTraceRefcntImpl::DumpStatistics: 2 entries

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 2181

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          15       16 378266655        1 (16062.33 +/-  9426.08) 101596886        1 (12212.57 +/- 20762.57)
  82 GenericFactory                                 16       16      359        1 (  179.75 +/-   103.56)   494109        1 (  334.32 +/-    45.32)

nsTraceRefcntImpl::DumpStatistics: 1276 entries
TEST-PASS | automationutils.processLeakLog() | no leaks detected!
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 16 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of GenericFactory with size 16 bytes
==> process 2213 will purposefully crash
INFO | automationutils.processLeakLog() | process 2213 was deliberately crashed and thus has no leak log

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, plugin process 2224

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          15        0      738        0 (   27.88 +/-    22.70)      435        0 (   63.91 +/-    52.77)

nsTraceRefcntImpl::DumpStatistics: 20 entries
TEST-PASS | plugin process 2224 | automationutils.processLeakLog() | no leaks detected!
==> process 2222 will purposefully crash
INFO | automationutils.processLeakLog() | process 2222 was deliberately crashed and thus has no leak log
==> process 2220 will purposefully crash
INFO | automationutils.processLeakLog() | process 2220 was deliberately crashed and thus has no leak log
==> process 2206 will purposefully crash
INFO | automationutils.processLeakLog() | process 2206 was deliberately crashed and thus has no leak log

INFO | runtests.py | Running tests: end.
program finished with exit code 0
elapsedTime=708.851926
Reporter

Updated

8 years ago
Summary: Intermittent TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 16 bytes during test execution | leaked 1 instance of GenericFactory → Intermittent TEST-UNEXPECTED-FAIL | leaked 16 bytes during test execution | leaked 1 instance of GenericFactory
Reporter

Updated

8 years ago
Summary: Intermittent TEST-UNEXPECTED-FAIL | leaked 16 bytes during test execution | leaked 1 instance of GenericFactory → Intermittent TEST-UNEXPECTED-FAIL | leaked 16 (or 32) bytes during test execution | leaked 1 instance of GenericFactory
https://tbpl.mozilla.org/php/getParsedLog.php?id=7168985&tree=Mozilla-Inbound
Summary: Intermittent TEST-UNEXPECTED-FAIL | leaked 16 (or 32) bytes during test execution | leaked 1 instance of GenericFactory → Intermittent TEST-UNEXPECTED-FAIL | leaked 16 (or 32) bytes during test execution | leaked 1 (or 2) instance of GenericFactory
Whiteboard: [orange]
(In reply to Chris Jones [:cjones] [:warhammer] from comment #271)
> Bug 805333 seems to have exacerbated this, but it might also just be bad luck
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=17658870&tree=Firefox
> https://tbpl.mozilla.org/php/getParsedLog.php?id=17662950&tree=Firefox


Seems strange that this is related to this bug. Almost all the code of the bug is disabled for desktop builds. Then the audio component doesn't involve the GenericFactory at all.

How can we debug it more?
I'm having problem reproducing this bug. Can someone point me to some mochitest for central?
https://tbpl.mozilla.org/php/getParsedLog.php?id=18413013&tree=Mozilla-Aurora
Rev3 WINNT 6.1 mozilla-aurora debug test mochitest-other [testfailed]

TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 16 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of GenericFactory with size 16 bytes
https://tbpl.mozilla.org/php/getParsedLog.php?id=20268665&tree=Firefox
Summary: Intermittent TEST-UNEXPECTED-FAIL | leaked 16 (or 32) bytes during test execution | leaked 1 (or 2) instance of GenericFactory → Intermittent TEST-UNEXPECTED-FAIL | leaked 16, 32, or 96 bytes during test execution | leaked 1, 2, or 3 instances of GenericFactory
https://tbpl.mozilla.org/php/getParsedLog.php?id=20567432&tree=Mozilla-Inbound

Any idea who can look into this? It affects basically every branch we maintain and is quite persistent.
I looked at a dozen or so of these.  They were all on Moth.  All but one looked like Win7.
Assignee: nobody → continuation
I added some logging for GenericFactory.  Hopefully there aren't too many of those...

https://tbpl.mozilla.org/?tree=Try&rev=07c5f12d7ebd
(In reply to Andrew McCreight [:mccr8] from comment #362)
> I looked at a dozen or so of these.  They were all on Moth.  All but one
> looked like Win7.

Other than the big chunk of dataloss where December/January/February got thrown on the floor, that's the sort of question that Orange Factor really wants to help you with, in https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=690604&tree=trunk&startday=2011-09-26&endday=2013-03-14. Alas, it doesn't want to tell you *why* it started out being almost entirely Linux, and then shifted to mostly Windows and then to nearly all Windows.
I could imagine that this would be fixed by bug 684887.  I guess we'll see over the next few days.  I wasn't able to reproduce it in 20 or so runs on Try, though I did get bug 694254 about 25% of the time!
Clearly this bug was so afraid of me that it fixed itself.

Or in actuality, I'm going to call this fixed by bug 684887.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684887
\o/

/me gets to work finding the next intermittent leak for mccr8 to scare straight.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
De-assigning myself because this was fixed already on trunk by another bug.
Assignee: continuation → nobody
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.