Last Comment Bug 690648 - Clarify popup-only move/resize window preference label
: Clarify popup-only move/resize window preference label
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: 7 Branch
: All All
: -- normal (vote)
: Firefox 10
Assigned To: Frank Yan (:fryn)
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
Depends on:
Blocks: 565541
  Show dependency treegraph
 
Reported: 2011-09-29 21:16 PDT by Masatoshi Kimura [:emk]
Modified: 2011-10-16 03:19 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.22 KB, patch)
2011-09-29 21:29 PDT, Frank Yan (:fryn)
dao+bmo: review-
faaborg: ui‑review+
Details | Diff | Splinter Review
patch v2 [ui-r=faaborg] (2.49 KB, patch)
2011-10-13 13:23 PDT, Frank Yan (:fryn)
dao+bmo: review-
Details | Diff | Splinter Review
patch v3 [ui-r=faaborg] (2.51 KB, patch)
2011-10-14 14:50 PDT, Frank Yan (:fryn)
dao+bmo: review+
Details | Diff | Splinter Review

Description Masatoshi Kimura [:emk] 2011-09-29 21:16:56 PDT
The label "Move or resize existing windows" is not accurate because we do no longer allow moving or resizing main window regardless of the option state.
It should be changed to something like "Move or resize popup windows".
Comment 1 Frank Yan (:fryn) 2011-09-29 21:29:04 PDT
Created attachment 563648 [details] [diff] [review]
patch
Comment 2 Dão Gottwald [:dao] 2011-09-30 04:38:59 PDT
Comment on attachment 563648 [details] [diff] [review]
patch

Need to change the entity name so that localizers pick up the change.
Comment 3 Frank Yan (:fryn) 2011-10-13 13:23:33 PDT
Created attachment 566919 [details] [diff] [review]
patch v2 [ui-r=faaborg]

Rev'd entity names.
Comment 4 Dão Gottwald [:dao] 2011-10-14 02:36:24 PDT
Comment on attachment 566919 [details] [diff] [review]
patch v2 [ui-r=faaborg]

moveResizePopupWindows? moveResizeWindows2 is kind of silly.

The checkbox id could be updated as well, although this is less important since it's unused.
Comment 5 Frank Yan (:fryn) 2011-10-14 14:50:26 PDT
Created attachment 567188 [details] [diff] [review]
patch v3 [ui-r=faaborg]

(In reply to Dão Gottwald [:dao] from comment #4)
> moveResizePopupWindows? moveResizeWindows2 is kind of silly.

Good idea.
Comment 7 Tim Taubert [:ttaubert] 2011-10-16 03:19:36 PDT
https://hg.mozilla.org/mozilla-central/rev/7feb84367f15

Note You need to log in before you can comment on or make changes to this bug.