Last Comment Bug 690658 - Duplicate twitter search engine listed in search bar
: Duplicate twitter search engine listed in search bar
Status: RESOLVED WORKSFORME
[qa+]
: regression
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: 8 Branch
: All All
: -- normal (vote)
: ---
Assigned To: [:Cww]
:
: Florian Quèze [:florian] [:flo]
Mentors:
Depends on:
Blocks: 671307
  Show dependency treegraph
 
Reported: 2011-09-29 22:48 PDT by Jithin Emmanuel
Modified: 2016-05-18 11:29 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
+
-


Attachments

Description Jithin Emmanuel 2011-09-29 22:48:07 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20110928060149

Steps to reproduce:

Upgraded to Firefox 8 beta. I already have Twitter Address Bar search addon installed.


Actual results:

I now see two Twitter listed in search bar. And the "Manage search engines" UI was not of the proper size and OK buttons was hidden. Spent some time figuring out why my Remove action was not working.


Expected results:

There should not be two twitter search engines. And the manage search engine UI should of proper size so that users can see the OK button.

Search made by the 2 twitter search engines differ by partner.
https://twitter.com/search/mysql?partner=Firefox&source=desktop-search
https://twitter.com/search/mysql?partner=mozilla&source=desktop-search

I believe 1st one is from Twitter Address Bar search addon and later from new change in Firefox 8 beta.
Comment 1 Henrik Skupin (:whimboo) 2011-09-30 00:28:12 PDT
Looks clearly like a regression from bug 671307. Vlad, can you please confirm?
Comment 2 Vlad [QA] 2011-09-30 07:31:10 PDT
I confirm the behavior: upgrading from Firefox 7.0.1 to Firefox 8.0 beta 1 on Win 7 x86 with Twitter Adress Bar is duplicating Twitter search engine in the search bar.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-09-30 09:50:36 PDT
(In reply to Henrik Skupin (:whimboo) from comment #1)
> Looks clearly like a regression from bug 671307.

Not really - rather a bad interaction between that and the addon.

It seems to have a hack where it attempts to hide any existing Twitter search plugins, and replace it with a "Twitter " (note the space). I don't see offhand why that would cause this, though.
Comment 4 Ed Lee :Mardak 2011-09-30 10:46:48 PDT
Looking at the patch, the name of the engine is "Twitter" and uses a partner code "Firefox":

https://bug671307.bugzilla.mozilla.org/attachment.cgi?id=558447
+<ShortName>Twitter</ShortName>
+  <Param name="partner" value="Firefox"/>

I don't see two in the search bar after installing though:

Components.utils.import("resource://gre/modules/Services.jsm"); JSON.stringify(Services.search.getEngines().map(function(e) [e.name, e.hidden]))

Before install:
[["Google",false],["Yahoo",false],["Bing",false],["Amazon.com",false],["eBay",false],["Twitter",false],["Wikipedia (en)",false]]

After install:
[["Google",false],["Twitter ",false],["Yahoo",false],["Bing",false],["Amazon.com",false],["eBay",false],["Twitter",true],["Wikipedia (en)",false]]

After uninstall:
[["Google",false],["Yahoo",false],["Bing",false],["Amazon.com",false],["eBay",false],["Twitter",false],["Wikipedia (en)",false]]
Comment 5 christian 2011-10-25 20:40:44 PDT
---------------------------------[ Triage Comment ]---------------------------------

Doubt this needs to be fixed before release, but we should track until we get a definitive answer.

Kev? Asa? How many people are potentially affected by this? Do we care for Firefox 8? We need a resolution asap, even if that resolution is saying we'll live with the behavior
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-10-26 09:56:17 PDT
QA chiming in here. I am of the opinion that if we have a fix in hand, lets land it on beta (it would seem pretty low risk to me); if we don't have a fix in hand, let it ride.
Comment 7 christian 2011-10-31 16:05:39 PDT
Thanks anthony. Poke Kev/Asa...
Comment 8 Asa Dotzler [:asa] 2011-11-01 08:21:32 PDT
I agree with Anthony. Do we need a relnote or support article ready or anything like that?
Comment 9 Ioana (away) 2011-11-01 08:57:52 PDT
I've verified this issue on Windows XP and Ubuntu 11.10 x86 and it works fine for me.

The Twitter Address Bar Search add-on was installed on Firefox 7.0.1 and the Twitter search engine was added in the search engines list. Afterwards, Firefox was upgraded to 8.0 beta 6. After the upgrade, the Twitter search engine was only listed once in the search engines list from the search bar (no duplicates).

It also WFM when trying to reproduce with Firefox 7.0 beta 5 instead of 7.0.1.
Comment 10 christian 2011-11-07 15:26:51 PST
Added to the release notes for Firefox 8.
Comment 11 Alex Keybl [:akeybl] 2011-12-05 19:36:24 PST
Since this was important enough to relnote, we should probably make sure that nobody is running into the issue now on SUMO (since it sounds like we weren't able to repro internally). If people are still, we should continue the investigation.
Comment 12 Alex Keybl [:akeybl] 2012-01-06 09:07:56 PST
Cheng - can you check to see whether this is still an issue on input/etc.? If not, I think we can untrack and assign to nobody.
Comment 13 Michelle Funches - QA 2016-05-18 11:29:19 PDT
This bug has been tagged for regression and or closure.
Appears there have been updates to this functionality
In latest release I am not seeing problems with search preferences or when applying the Twitter AddOn
Closing as Resolved-WFM
If anyone can still produce an issue, please provide updates to STR/OS and Fx versions.

Note You need to log in before you can comment on or make changes to this bug.