error: couldn't compile a simple C file with some versions of binutils

RESOLVED FIXED in mozilla10

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla10
All
Linux
Points:
---

Firefox Tracking Flags

(firefox8 affected, firefox9 affected)

Details

(Whiteboard: [inbound])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
The error looks like this:
checking whether removing dead symbols breaks debugging... configure: error: couldn't compile a simple C file

The problem comes from an LD bug: http://sourceware.org/bugzilla/show_bug.cgi?id=13195

Instead of failing, we should just disable dead symbol removal.
(Assignee)

Updated

6 years ago
status-firefox8: --- → affected
status-firefox9: --- → affected
(Assignee)

Updated

6 years ago
Assignee: nobody → mh+mozilla
(Assignee)

Updated

6 years ago
Blocks: 670659
(Assignee)

Comment 1

6 years ago
Created attachment 563685 [details] [diff] [review]
Disable dead symbol removal when failing to test for bug 670659
Attachment #563685 - Flags: review?(ted.mielczarek)
Comment on attachment 563685 [details] [diff] [review]
Disable dead symbol removal when failing to test for bug 670659

Review of attachment 563685 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +6889,5 @@
>                  GC_SECTIONS_BREAKS_DEBUG_RANGES=yes
>              fi
>          else
>               dnl We really don't expect to get here, but just in case
> +             GC_SECTIONS_BREAKS_DEBUG_RANGES="no, but it's broken in some other way"

Seems a little weird to stick an arbitrary string in here. Maybe you should just use "yes"?
Attachment #563685 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 3

6 years ago
(In reply to Ted Mielczarek [:ted, :luser] from comment #2)
> Seems a little weird to stick an arbitrary string in here. Maybe you should
> just use "yes"?

"yes" would be lying, since the issue is entirely different ; and an arbitrary string is supported just fine.
(Assignee)

Comment 4

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/0151c893093e
Whiteboard: [inbound]
https://hg.mozilla.org/mozilla-central/rev/0151c893093e
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
You need to log in before you can comment on or make changes to this bug.