Closed Bug 690699 Opened 8 years ago Closed 8 years ago

Addon Manager severely broken if autoUpdateDefault preference is missing

Categories

(Toolkit :: Add-ons Manager, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla10

People

(Reporter: glazou, Assigned: Unfocused)

References

Details

(Keywords: regression, Whiteboard: [fixed-in-fx-team])

Attachments

(1 file)

Undocumented pref "extensions.update.autoUpdateDefault" breaks the Addon Manager
if it's not defined, because the call to that pref in AddonManager.jsm is
not try/catch'd. It _must_ be try/catch'd...

Since that preference has not been documented, no third-party
embedder knows about it, and that's why my just released BlueGriffon 1.2's Addon
Manager is severely broken on addon install and removal... I'll have to release
a 1.2.1 because of this bug:-(
Regression from bug 596343 - there was originally a try/catch there, which that bug removed (and shouldn't have - seems that change was missed in the review).
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Keywords: regression
Attached patch Patch v1Splinter Review
Attachment #565134 - Flags: review?(dtownsend)
Attachment #565134 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/integration/fx-team/rev/d358b165eee4
Flags: in-testsuite-
Flags: in-litmus-
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla10
https://hg.mozilla.org/mozilla-central/rev/d358b165eee4
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.