Last Comment Bug 690700 - Remove PR_TRUE/PR_FALSE from widget/src/gtk2
: Remove PR_TRUE/PR_FALSE from widget/src/gtk2
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla10
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
Mentors:
Depends on:
Blocks: 675553
  Show dependency treegraph
 
Reported: 2011-09-30 02:30 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2011-11-28 16:39 PST (History)
5 users (show)
masayuki: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (177.73 KB, patch)
2011-09-30 02:30 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
karlt: review+
Details | Diff | Splinter Review
part.2 Remove MAKE_PR_BOOL (1.14 KB, patch)
2011-10-01 20:02 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
karlt: review+
Details | Diff | Splinter Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-09-30 02:30:24 PDT
Created attachment 563698 [details] [diff] [review]
Patch

https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=505027082410

([ ,({])PR_TRUE([ ,);}\n]) and ([ ,({])PR_FALSE([ ,);}\n]) are replaced with true and false. And I fixed two lines which is in string for log (nsDragService::GetData()) manually.
Comment 1 Dave Garrett 2011-09-30 13:18:13 PDT
Instead of updating the MAKE_PR_BOOL macro, it looks like you can just remove it entirely. Not only is it generally obsolete but it appears to only be defined and not used.
http://mxr.mozilla.org/mozilla-central/search?string=MAKE_PR_BOOL
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-10-01 20:02:02 PDT
Created attachment 564014 [details] [diff] [review]
part.2 Remove MAKE_PR_BOOL

Sure.
Comment 3 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-10-01 20:03:31 PDT
NOTE: both MAKE_PR_BOOL have no user.
Comment 4 Karl Tomlinson (:karlt) 2011-10-02 23:18:16 PDT
Comment on attachment 563698 [details] [diff] [review]
Patch

>-  gtk_file_chooser_set_do_overwrite_confirmation(GTK_FILE_CHOOSER(file_chooser), PR_TRUE);
>+  gtk_file_chooser_set_do_overwrite_confirmation(GTK_FILE_CHOOSER(file_chooser), true);

>-    GdkPixbuf* pixbuf = gdk_pixbuf_new(GDK_COLORSPACE_RGB, PR_TRUE, 8,
>+    GdkPixbuf* pixbuf = gdk_pixbuf_new(GDK_COLORSPACE_RGB, true, 8,

These function expect gboolean, so please use "TRUE" here.

>-    gboolean value = PR_FALSE;
>+    gboolean value = false;

Similarly, "FALSE" here.
Comment 6 Marco Bonardo [::mak] 2011-10-03 08:01:03 PDT
https://hg.mozilla.org/mozilla-central/rev/450f539a3dab
https://hg.mozilla.org/mozilla-central/rev/696394093f34

Please stop doing PR_TRUE/PR_FALSE convertions till the PRBool regression is figured out (see the topic in mozilla.dev.planning)
Comment 7 Armen Zambrano [:armenzg] (EDT/UTC-4) 2011-11-28 12:38:43 PST
Hi,
We are looking into why tp5 for Win7 could have become bimodal after Oct. 3rd in bug 697092.
After much digging up the changeset 696394093f34 has become our main suspect (we're are narrowing down the variables).

Is there any way you think this patch could have caused this?
Any help will be very much appreciated as this type of distributions prevents anyone to determine when new performance regressions happen.

Thanks a lot!

http://graphs-new.mozilla.org/graph.html#tests=[[89,63,12],[115,1,12],[115,63,12]]&sel=1314736531811,1322512531811&displayrange=90&datatype=running
Comment 8 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-28 16:36:42 PST
Armen:

This bug just replaced PR_TRUE/PR_FALSE with true/false (or TRUE/FALSE for gboolean).
Comment 9 Karl Tomlinson (:karlt) 2011-11-28 16:39:12 PST
Answered in bug 697092 comment 13.

Note You need to log in before you can comment on or make changes to this bug.