Closed Bug 690898 Opened 11 years ago Closed 9 years ago

Use pre-built SQLite DBs when creating a new profile

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 699615

People

(Reporter: mfinkle, Unassigned)

References

Details

(Keywords: mobile, perf, Whiteboard: mobilestartupshrink)

When creating a new profile in Firefox Mobile, it takes a long time. Much of this is time spent building SQLite databases using SQL commands.

It might be interesting to see if we can make the process faster by copying pre-built DBs into the new profile.
Early benchmarking seems to hint that much of the time spent in SQLite is actually spent committing files to storage. By using fs-based transactions instead of sqlite-based transactions, we can probably remove most of this overhead, without having to grow the binary.

Barring any accident, I'm starting work on this today.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 699615
You need to log in before you can comment on or make changes to this bug.