Last Comment Bug 690962 - Remove useless assertion now that we use bool instead of PRBool
: Remove useless assertion now that we use bool instead of PRBool
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla10
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
:
Mentors:
: 691124 (view as bug list)
Depends on: 675553
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 16:17 PDT by Ben Turner (not reading bugmail, use the needinfo flag!)
Modified: 2011-10-03 08:03 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (581 bytes, patch)
2011-09-30 16:23 PDT, Ben Turner (not reading bugmail, use the needinfo flag!)
dbaron: review+
Details | Diff | Splinter Review

Description Ben Turner (not reading bugmail, use the needinfo flag!) 2011-09-30 16:17:57 PDT
Now that bug 675553 landed this is worthless.

c:\Home\src\mozilla\telephony\obj-debug\dist\include\nsPresContext.h(678) : warning C4806: '&' : unsafe operation: no value of type 'bool' promoted to type 'int' can equal the given constant
Comment 1 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-09-30 16:23:39 PDT
Created attachment 563885 [details] [diff] [review]
Patch
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-09-30 16:29:33 PDT
Comment on attachment 563885 [details] [diff] [review]
Patch

r=dbaron, but could you remove all 4 of them in this file rather than just this 1
Comment 3 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-10-02 08:03:51 PDT
*** Bug 691124 has been marked as a duplicate of this bug. ***
Comment 4 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-10-02 14:00:47 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6127f8fddb96
Comment 5 Marco Bonardo [::mak] 2011-10-03 08:03:30 PDT
https://hg.mozilla.org/mozilla-central/rev/6127f8fddb96

Note You need to log in before you can comment on or make changes to this bug.