Cannot drag and drop tabs into bookmark toolbar

RESOLVED DUPLICATE of bug 675507

Status

()

RESOLVED DUPLICATE of bug 675507
7 years ago
7 years ago

People

(Reporter: DJCHalkley, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111001 Firefox/10.0a1
Build ID: 20111001030845

Steps to reproduce:

It has been an issue since Firefox nightly 9 update (a while back) and has not been fixed in Firefox nightly 10 alpha.


Actual results:

When trying to drag and drop a tab into the bookmark(s) toolbar nothing happens, the tab does cannot move upwards (seems to be fixed) (however I can still drag and drop to create a new Firefox window).


Expected results:

It should allow for me to create bookmarks by dragging and dropping into the bookmark toolbar. It has come a real pain to use the ctrl+d method than having to go and rearrange my bookmarks.
(Reporter)

Comment 1

7 years ago
tab cannot move*
(Reporter)

Updated

7 years ago
Hardware: x86 → x86_64

Comment 2

7 years ago
I also have this problem.
Please listen to me, Firefox's developer, new Firefox tab animation not only make user can't drag tab to bookmark toolbar, it make Firefox become unfriendly, so much user is using this way to create new bookmark.

I know that user can drag Location Bar favicon to bookmark toolbar or hold CTRL when drag, but only few people know that way. Not ALL!

And not only about bookmark toolbar, the new tab animation break Tab Mix Plus and Multi Tab Handler
- https://addons.mozilla.org/en-US/firefox/addon/tab-mix-plus/
- https://addons.mozilla.org/en-US/firefox/addon/multiple-tab-handler/

You can read this thread: http://forums.mozillazine.org/viewtopic.php?f=23&t=2321291
And some other add-ons.

Only animation when moving tab but break that much add-on, so I think you should introduce this feature to Firefox. Please think about Multi-tab Select, Private Browsing on new window, these two feature is not important ? No! It very very important.
- Multi-tab select is really helpful, this feature is very possible to add, it have in Multi Tab Handler: https://addons.mozilla.org/en-US/firefox/addon/multiple-tab-handler/
This feature will help user move multiple tab to a new window, close multiple tab, move multiple tab to Panorama, it is quite useful! And all you need are built-in it from Multi Tab Handler to Firefox, you have all source code.
- Know that open Private Browsing on a new window is in progress, ok, no problem.

Once again, about Firefox new "Tab move detact animation", it is not a useful feature, in Chrome, they hide selected window(this window only have one tab) when user is moving tab, this make easier to drag tab to another window. View my video: http://www.swfcabin.com/open/1313411661

Animation is useless, it is just make user "feel" that Firefox faster, but in fact, it is just slow down Firefox, and will freeze on slow computer, example, my laptop, laptop is not fast as desktop computer, but will laptop users must use Opera, but i'm a Firefox's fan, I have so much add-on that Opera never have ? 
I must disable all Firefox animation to prevent Firefox from freeze. Animation will eat CPU, you know that.

So, please remove this feature on Firefox 8, 9, 10. I never think this feature will make Firefox better, anyway.

I suggest you just hide selected window when moving Firefox tab, and do not add so much animation to Firefox, please think about slow computer and laptop, from Firefox 4.0, Firefox use much computer resource than Firefox 3.6, that is why user still stuck with Firefox 3.6, not upgrade to Firefox 4,5,6,7...

Thank for read,
Best regard,
Cattleya.

Comment 3

7 years ago
Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=675507 ?

Best regards,
jonatan.

Comment 4

7 years ago
I can also see the issue reported here on the latest Nightly build:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111003 Firefox/10.0a1

But this maybe happening because of the implementation of the Tab Animation Feature:
wiki page: https://wiki.mozilla.org/Firefox/Features/Tab_move_detach_animations
tracking bug: https://bugzilla.mozilla.org/show_bug.cgi?id=455694

Bug 674723 might refer or be similar to this issue (dragging to bookmark toolbar is similar to dragging to bookmarks library). Please have a look and decide if  a duplicate. Thanks

p.s. dragging a tab to the bookmarks toolbar is currently possible if you drag the favicon.
(Reporter)

Comment 5

7 years ago
Thanks for your help guys

It seems that this is not a bug but however a feature that is somewhat undesirable, there should be an option (a way) to turn it off... Don't go changing something that doesn't need fixing... Ohh well I will have to get used to using ctrl + drag and the using the icon thing to create my bookmarks.

Again thank-you for your help
 
-Cheers David C
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675507
You need to log in before you can comment on or make changes to this bug.