Last Comment Bug 691118 - "ASSERTION: aPrevFrame must be the last continuation in its chain!"
: "ASSERTION: aPrevFrame must be the last continuation in its chain!"
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: :Ehsan Akhgari (out sick)
:
Mentors:
Depends on:
Blocks: randomstyles 10209
  Show dependency treegraph
 
Reported: 2011-10-01 23:24 PDT by Jesse Ruderman
Modified: 2012-01-04 04:50 PST (History)
8 users (show)
ehsan: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (496 bytes, text/html)
2011-10-01 23:24 PDT, Jesse Ruderman
no flags Details
stack trace (4.40 KB, text/plain)
2011-10-01 23:24 PDT, Jesse Ruderman
no flags Details
Patch (v1) (2.77 KB, patch)
2011-10-07 13:26 PDT, :Ehsan Akhgari (out sick)
no flags Details | Diff | Review
Patch (v2) (2.56 KB, patch)
2012-01-03 13:26 PST, :Ehsan Akhgari (out sick)
roc: review+
Details | Diff | Review

Description Jesse Ruderman 2011-10-01 23:24:21 PDT
Created attachment 564018 [details]
testcase

###!!! ASSERTION: aPrevFrame must be the last continuation in its chain!: '!aPrevFrame || (!aPrevFrame->GetNextContinuation() || IS_TRUE_OVERFLOW_CONTAINER(aPrevFrame->GetNextContinuation())) && !IS_TRUE_OVERFLOW_CONTAINER(aPrevFrame)', file layout/base/nsFrameManager.cpp, line 497
Comment 1 Jesse Ruderman 2011-10-01 23:24:40 PDT
Created attachment 564019 [details]
stack trace
Comment 2 Timothy Nikkel (:tnikkel) 2011-10-05 19:13:24 PDT
Caused by something between fc7e928eaeae and af3668a89015, ie bug 10209.
Comment 3 :Ehsan Akhgari (out sick) 2011-10-07 13:26:15 PDT
Created attachment 565635 [details] [diff] [review]
Patch (v1)

I don't think that the assertion actually makes any sense for absolute frames.
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-10-07 13:54:37 PDT
Why's that?
Comment 5 :Ehsan Akhgari (out sick) 2011-10-12 08:09:48 PDT
Because we're not appending a frame after aPrevFrame.  Or at least, it should be possible to append an absolute frame in that case.
Comment 6 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-10-17 04:26:45 PDT
aPrevFrame would be the previous abs-pos frame.
Comment 7 :Ehsan Akhgari (out sick) 2011-12-30 15:03:29 PST
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #6)
> aPrevFrame would be the previous abs-pos frame.

But still, does the assertion make sense?  We don't require abs-pos frames to be overflow containers, right?
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-12-30 15:52:54 PST
They can't be true overflow containers, actually. See the definition of IS_TRUE_OVERFLOW_CONTAINER.

I think probably instead of checking IS_TRUE_OVERFLOW_CONTAINER we should just check for the NS_FRAME_IS_OVERFLOW_CONTAINER state bit.
Comment 9 :Ehsan Akhgari (out sick) 2012-01-03 13:26:51 PST
Created attachment 585539 [details] [diff] [review]
Patch (v2)
Comment 10 :Ehsan Akhgari (out sick) 2012-01-03 16:45:26 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/56ee31100cf6
Comment 11 Mozilla RelEng Bot 2012-01-03 17:31:06 PST
Try run for 689ef914ab82 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=689ef914ab82
Results (out of 208 total builds):
    exception: 3
    success: 181
    warnings: 23
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.com-689ef914ab82
Comment 12 Marco Bonardo [::mak] 2012-01-04 04:50:36 PST
https://hg.mozilla.org/mozilla-central/rev/56ee31100cf6

Note You need to log in before you can comment on or make changes to this bug.