Last Comment Bug 691135 - intl: AURORA_BASE_20110927 fails to build darwin/x11
: intl: AURORA_BASE_20110927 fails to build darwin/x11
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla11
Assigned To: Hanspeter Niederstrasser
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-02 03:17 PDT by Jeremy Huddleston
Modified: 2012-02-01 14:00 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
locale should use mac on Macs (523 bytes, patch)
2011-11-11 13:21 PST, Hanspeter Niederstrasser
ted: review+
Details | Diff | Splinter Review
locale should use mac on Macs (720 bytes, patch)
2011-11-16 08:17 PST, Hanspeter Niederstrasser
ted: review+
Details | Diff | Splinter Review

Description Jeremy Huddleston 2011-10-02 03:17:33 PDT
make libs
nsI18nModule.cpp
/Developer/usr/bin/clang++ -arch x86_64 -o nsI18nModule.o -c  -fvisibility=hidden -DXPCOM_TRANSLATE_NSGM_ENTRY_POINT=1 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DSTATIC_EXPORTABLE_JS_API -DOSTYPE=\"Darwin11.2.0\" -DOSARCH=Darwin -I./../lwbrk/src -I./../unicharutil/src -I./../strres/src -I./../locale/src -I./../locale/src/unix  -I. -I. -I../../dist/include -I../../dist/include/nsprpub  -I/opt/local/var/macports/build/_Volumes_Home_jeremy_src_macports_trunk_dports_www_firefox-x11-devel/firefox-x11-devel/work/mozilla-central/dist/include/nspr -I/opt/local/var/macports/build/_Volumes_Home_jeremy_src_macports_trunk_dports_www_firefox-x11-devel/firefox-x11-devel/work/mozilla-central/dist/include/nss      -fPIC -I/opt/local/include -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pipe -O2 -arch x86_64 -fno-strict-aliasing -fno-common -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -g -O2 -fomit-frame-pointer  -I/opt/local/include -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/nsI18nModule.pp /opt/local/var/macports/build/_Volumes_Home_jeremy_src_macports_trunk_dports_www_firefox-x11-devel/firefox-x11-devel/work/mozilla-central/intl/build/nsI18nModule.cpp
In file included from /opt/local/var/macports/build/_Volumes_Home_jeremy_src_macports_trunk_dports_www_firefox-x11-devel/firefox-x11-devel/work/mozilla-central/intl/build/nsI18nModule.cpp:61:
./../locale/src/nsLocaleConstructors.h:73:10: fatal error: 'nsCollationMacUC.h' file not found
#include "nsCollationMacUC.h"
         ^
1 error generated.
make[1]: *** [nsI18nModule.o] Error 1
make: *** [default] Error 2

This patch addresses the build, but I'm not sure if it's "correct" as you may want this code for mac since it's probably not cocoa specific... which means you should be generating that header file somewhere.

--- a/intl/locale/src/nsLocaleConstructors.h
+++ b/intl/locale/src/nsLocaleConstructors.h
@@ -45,21 +45,21 @@
 #include "nsILocaleService.h"
 #include "nsIScriptableDateFormat.h"
 #include "nsIServiceManager.h"
 #include "nsLanguageAtomService.h"
 #include "nsCharsetAlias.h"
 #include "nsPlatformCharset.h"
 #include "nsLocaleCID.h"
 
-#if defined(XP_MACOSX)
+#if defined(MOZ_WIDGET_COCOA)
 #define USE_MAC_LOCALE
 #endif
 
-#if defined(XP_UNIX) && !defined(XP_MACOSX)
+#if defined(XP_UNIX) && !defined(MOZ_WIDGET_COCOA)
 #define USE_UNIX_LOCALE
 #endif
 
 #ifdef XP_WIN
 #include "nsCollationWin.h"
 #include "nsDateTimeFormatWin.h"
 #endif
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-10-02 03:23:08 PDT
I guess you could try patching intl/locale/src/Makefile.in instead.
Comment 2 Hanspeter Niederstrasser 2011-11-11 13:21:43 PST
Created attachment 573906 [details] [diff] [review]
locale should use mac on Macs

Patching in intl/build/Makefile.in because that's where nsI18nModule.o is actually getting built from
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-11-16 07:49:23 PST
If you could generate a patch as described at <https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F>, that'd be appreciated...
Comment 4 Hanspeter Niederstrasser 2011-11-16 08:17:41 PST
Created attachment 574904 [details] [diff] [review]
locale should use mac on Macs

Hope this works.  When saving the checkin comment from Vi after 'hg qnew name.patch' it decided to save the comment some 690000 times (though I think that's because I started typing the bug # before typing 'i' in Vi).  I manually cut the excess lines out afterwards.

Carrying the r+ from the previous patch.
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2011-11-16 08:19:48 PST
Looks great, thanks
Comment 6 Hanspeter Niederstrasser 2011-11-16 08:20:24 PST
Comment on attachment 574904 [details] [diff] [review]
locale should use mac on Macs

Grrr.  So apparently the r+ from another user can't just be copied over to a new patch.
Comment 7 Ted Mielczarek [:ted.mielczarek] 2011-11-16 08:39:25 PST
Comment on attachment 574904 [details] [diff] [review]
locale should use mac on Macs

Review of attachment 574904 [details] [diff] [review]:
-----------------------------------------------------------------

Generally it's okay to just set the r+ flag yourself if you've received r+ on a previous version of the patch and you have only made changes the reviewer suggested.
Comment 9 Ed Morley [:emorley] 2011-11-19 05:14:33 PST
https://hg.mozilla.org/mozilla-central/rev/5f4bb56e4049

Note You need to log in before you can comment on or make changes to this bug.