Last Comment Bug 691138 - ipc: AURORA_BASE_20110927 fails to build darwin/x11
: ipc: AURORA_BASE_20110927 fails to build darwin/x11
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Jeremy Huddleston
:
: [PTO to Dec5] Bill McCloskey (:billm)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-02 03:44 PDT by Jeremy Huddleston
Modified: 2011-10-14 08:18 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.20 KB, patch)
2011-10-02 03:44 PDT, Jeremy Huddleston
smichaud: review+
Details | Diff | Splinter Review

Description Jeremy Huddleston 2011-10-02 03:44:35 PDT
Created attachment 564041 [details] [diff] [review]
patch

6dc468c41136 (20110820) built fine, but the AURORA_BASE_20110927 tag fails with various issues in ipc (probably because someone assumed darwin == cocoa):

../../ipc/chromium/src/chrome/common/mach_ipc_mac.h:116:3: warning: conversion function converting 'MachMsgPortDescriptor' to its base class
      'mach_msg_port_descriptor_t' will never be used
  operator mach_msg_port_descriptor_t&() {
  ^
/opt/local/var/macports/build/_Volumes_Home_jeremy_src_macports_trunk_dports_www_firefox-x11-devel/firefox-x11-devel/work/mozilla-central/ipc/glue/GeckoChildProcessHost.cpp:49:10: fatal error: 
      'nsILocalFileMac.h' file not found
#include "nsILocalFileMac.h"
         ^
1 warning and 1 error generated.
make[1]: *** [GeckoChildProcessHost.o] Error 1
Comment 1 Steven Michaud [:smichaud] (Retired) 2011-10-13 14:46:35 PDT
Comment on attachment 564041 [details] [diff] [review]
patch

This looks fine to me.

XP_MACOSX and MOZ_WIDGET_COCOA are always synonyms when doing a
"normal" build on "normal" OS X.  So this change can't harm any of our
supported configurations.

It might (conceivably) cause trouble for someone trying to do a GTK or
QT build on OS X or (non-Cocoa) Darwin.  But it sounds like the very
reason for you wanting these changes is to make this kind of "non
normal" (non-supported) build possible.  So I'll take your word for it
that this helps, but we'll need to keep an eye out for problems.

By the way, I suspect there are	many places in the tree where
XP_MACOSX sections of code contain Cocoa dependencies.
Comment 2 Jeremy Huddleston 2011-10-13 19:13:34 PDT
Yes, and it seems like every 3-6 months, I need to send a handful of patches to mozilla to fix cases where people forget that.  This last month or so has been especially bad.  August 20th master built fine, but one month later (9/27) had tons of fallout.  I've submitted multiple patches, but they're insufficient.  I haven't had time to fix the remainder.

Note You need to log in before you can comment on or make changes to this bug.