browser.urlbar.trimURL should default to false

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Jamie Wilmoth, Unassigned)

Tracking

7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Upgraded to Firefox 7.


Actual results:

http:// in Location Bar stopped appearing.


Expected results:

browser.urlbar.trimURL should be false by default.  While it is a nice looking feature, and does make it look cleaner, it will cause more difficulties long-term than the benefits.

First, it will make invalid URIs when copying and pasting.  Email, IM, and other clients may then not interpret it correctly unless the one pasting manually puts the http:// back in each time.  If they do not, then everyone receiving it may be forced to manually copy and paste it into their browser instead of having a clickable link.  And for long URLs that may not be possible if the client splits it up over multiple lines because it did not recognize it as a valid URI.

Second, I do tech support over the phone.  A large amount of the time I ask someone to type a simple URL into their browser, they put it into the Search Bar instead of the Address/Location Bar.  The only consistent cross-browser way I can have them find the correct spot is to "look for the line near the top starting with 'http.'"  This feature will make it harder for the very people having the most difficulty and least understanding of the browser.  Which in turn makes it harder for me. :-)

However, advertising this feature in some manner, and letting those that have a comfortable understanding of how their browser works and its components choose it, I feel would be a better means of enabling it.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 680368

Comment 2

6 years ago
This is DEFINITELY not a duplicate of bug 680368.
This "trendy feature" should be DEFINITELY switched off BY DEFAULT.
It messes up many-many's site/forum engines that do smart URL highlighting.

I know I can do the change in about:config, but if FF dev team will continue to implement such "improvements" - I'll stay with FF6 and finally will switch to some alternative browser, even IE (oh my! :)

Comment 3

6 years ago
Reopened as not a duplicate.

This bug wants the default value of an option changed. 
Bug 680368 asks for the option to appear in the preferences window 
so the option can be changed without using about:config.

p.s. Both indicate dissatisfaction with trimming of URLs.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 4

6 years ago
Then it will be WONTFIX, just as bug 680368.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX

Comment 5

6 years ago
A bit late on this bug, seeing that it has already been marked as won't fix, but I also think this is a terrible default. Not that it is that inconvenient, but it marks a general attitude that might tip me to another browser (though probably not IE).

Comment 6

6 years ago
You do know that Chrome also does the same thing, right ?

Comment 7

6 years ago
Well if google do it, it must be right - I see your point...

I can see that hiding complexity from a great number of users is probably a good thing, so I sort of get the reason, but why hide part of the URL, why not just hide the whole thing?

Anyway, I probably won't switch browsers. That comment was just a reaction of the dumbing down effect. I can always re-enable it (and have) for my own benefit. Firefox is a "good thing" as far as I am concerned.

And, the more I think about it, the more reasonable your approach seems. Keep up the good work.
(In reply to nigel.brown from comment #7)
> but why hide part of the URL, why
> not just hide the whole thing?

For security reasons you may want to see the address you are visiting, on the other side http doesn't add any useful security info.

Comment 9

6 years ago
Hello;
I'm really not complaining, I'm happy with the situation, nice browser!

However, just for the sake of constructive discourse your statement above assumes a user who does not want to see "http://" presumably because it confuses them who will also monitor the URL for unusual changes. 

Also, the difference between "http://" and "https://" is an important security distinction, though I appreciate there are other ways of telling if you are on a secure page.

Anyway, I'll remove my vote for this bug. Thanks both for the comments.

Comment 10

4 years ago
Another reason to get rid of this misfeature (beside promoting http instead of https) is an inconsistent handling of URLs.  Writing what you see should always get you to where you were, which is not the case for for example URLs starting with "ftp.": typing "ftp.debian.org" gets you to ftp://... rather than http://... as one would expect.

Comment 11

2 years ago
Please remark this as a duplicate of bug 680368. Thanks.

Comment 12

2 years ago
This is not a duplicate of 680368, as discussed in comments 2 and 3.
You need to log in before you can comment on or make changes to this bug.